So I have this annoying problem where I can't connect to the Pokemon GO app through mobile data. It will get stuck at around 20% and I can see that my phone will have no data exchange whatsoever. When I use WiFi however, I can connect perfectly fine, turn off WiFi and then play the game. I have the assumption that it has to do with my google account, through which I log on with. I have read multiple answers to this problem and none worked:

  • restarting app, phone
  • resetting app preferences
  • uninstalling/reinstalling app
  • setting google account settings to allow unsecure apps to use the google login
  • manually turning on and of various google applications from usage of mobile data

All this did not help a bit.

But I noticed something strange: when Ii connect through WiFi, I will have a window of about 10 minutes where I can connect through mobile data with WiFi disabled. However after these 10 minutes I will have to log in with WiFi turned on again. This leads me to assume that some kind of authentication process is done, that works through WiFi but not through mobile data and also has a small time window where it seems to be temporarily saved on the phone. I would really appreciate anyone's input in what might help, or what the problem could be.

  • 2
    @JAL the answer to the question over there was for iPhone users. I believe Zane has an android phone based on the tags.
    – Sync
    Commented Jul 27, 2016 at 16:35
  • @Sync would How can I find Pokémon Go's uptime? be a better target then?
    – JAL
    Commented Jul 27, 2016 at 16:36
  • 2
    Zane what phone are you using? Can you try disabling power saving mode and make sure that background data is enabled. It could be possible that data is much slower than WiFi so it is taking longer to authenticate. And if you don't mind mention who your phone provider is.
    – Sync
    Commented Jul 27, 2016 at 16:37
  • 1
    @JAL that's more for server related issues. I'm able to login right now with Google login (in Canada), so I don't think the servers are an issue atm.
    – Sync
    Commented Jul 27, 2016 at 16:43
  • I have disabled power saving mode and i have background data enabled (although i did try dissabling it, which did not help). It is not taking longer, it is not working at all. after 5 minutes it will lead to the "player information could not be retrieved from the server" pop-up. my phone is a honor 7 premium. Android version 5.0.2. my provider is the german congstar, daugther to the german telekom. But i doubt that this is the issue since my gf is using the exact same provider at the same location at the same time - with no problems logging in.
    – Zane
    Commented Jul 27, 2016 at 16:49

8 Answers 8


I've been experiencing the exact same problem and finally figured out what was causing this. Turned out I had disabled Google Play Store from using background data when not on WiFi, enabling this option allowed me to login without WiFi consistently.

Here's how I fixed this, hope this helps others.

Go to: Settings - Wireless & networks - Data usage Scroll down to and tap: Google Play Store Uncheck: Limit background data


Check to see if your Google Services has restricted background data, I unchecked my one and started working. You can do this the same way as the Google Play Services one.


I had the same frustrating issue for about 3 weeks. Could login to Pokemon Go every time through WiFi but gets stuck on the login screen every time through mobile network. What finally worked for me (Sony Z1 compact) was going to App --> Reset app preferences.


If you still can't use mobile data to login, you could try this method. Which works for my sister LG G2

Firstly, turn on mobile data, and turn off wifi

Go to settings, then to account, turn on auto sync (if didn't turn on yet)

Then click on your gmail, choose to manually sync which item, you can leave it auto sync all your stuffs

But the most important is the 'app data'. Make sure you click on sync once

If you already auto sync, try click sync at the 'app data' while on mobile data

You can try, and hope this helps


Using Samsung Note3 = go to Setting > Connection > Data Usage > press 'left - after MENU button' > Restricted Bcground Data > OK > 'UN-ticked'


I had exactly the same issue. It looks like I accidentally disabled Google Play Services from using Mobile data.

Go to Settings - Apps - Google Play services - Data usage - check "Mobile data".


I finally found how to fix this.

I've tried all this options and nothing worked until now

●Resetting app preferences ●Allowing less secure apps ●Restarting / Reinstalling ●Allowing background data

Nothing of this worked for me. What solved my Problem was going to the " Google-play service" and deleting all data and cache. AFTER THAT I went to Google location history and ACTIVATED the location history. It had some kind of bug which deactivated every time after I left the screen, so I had to complete deactivate for all my devices and activate again. It was showing that my device last connection was "unknown", it now shows the correct date. In a galaxy s7 you will find that option when you go to "options->google->location->Google location history".

I hope that helps. Bye.


I had the same problem. I fixed it by removing data restriction from google account manager.

Not the answer you're looking for? Browse other questions tagged .