5

I try to break blocks in single player but it just lags out and when I do, it breaks and then it reappears. I keep breaking it and then it eventually falls. I want it to stop.

P.S. It doesn't do this in Minecraft multiplayer.

2
  • Does this happen in all worlds, or just one?
    – SirBenet
    Jul 27 '16 at 19:55
  • All the worlds are like this but not the Multiplayer ones
    – MinesomeMC
    Jul 27 '16 at 20:31
5

It's weird that this only happens on single player, try these to see if they solve your problem

Change video settings.

If your Render Distance is high and your computer is trying to load a mass amount of chunks then this could cause your PC to lag. You can also turn Particles to low, Graphics to fast, and Clouds off.

Turn VBO's on

If you look in the Minecraft menu under Options then Video Settings You should see "Use VBOs" this is supposed to increase your FPS 5 to 10%

Read more on VBOs here.

Remove any possible lag content

Such as Mobs and other entities, snow, decaying leaves and more

you can find a whole list of things to remove here: What game mechanics in Minecraft cause lag?

The last thing you could do is install a lag reducing tool like OptiFine

There are plenty tutorials online on how to do this.

2
  • Just to add to this answer: If you've installed any mods and tried to delete them, you might have parts of a broken mod affecting your game. Finally, if none of these options work, you might want to have someone look at the PC as a whole as it could be lag from something else (Hard drive always in use) that's affecting MC as a side-effect.
    – NBN-Alex
    Jul 27 '16 at 21:47
  • @MinesomeMC, No prob. I'd like to know if any of these solve your problem.
    – Jason_
    Jul 28 '16 at 8:04
0

i am sadly not using optifine and i dont have vbo's option. i only wanted to test the bees today, and then tick lag makes them feel like i have slow internet on an overloaded server. they dont move. LITERALLY just floating there, as well as other mobs. blocks come back after being mined. then switching to optifine for more options i did a couple of stuff in the settings and it did kind of fix it.... but on a flat world, no lag AND no LAG at all. kind of makes me rage tbh... even with the lowest settings the tick lag still happens. trying this on a computer with a very expensive cpu on a computer cafe. it still happens. i did solve it by using optifine and disabling and enabling certain options...

Settings> Videos> i did turn on vbos as said. Enabled lazy chunk loading. Graphics> fast Clouds: off

less tick lag. but that doesn't mean it's totally gone. it's just reduced.

sorry for edit spam, my keyboard is kind of under the weather at the moment...

0

This same exact thing happened to me. I was mining & it took me like 5 tries before I could actually mine the block. It just kept on reappearing after I mined it.

how to fix this problem

  1. go to game menu (esc button) & then press "options..."
  2. press "video settings..." & turn smooth lighting: OFF.

Once you've done this, the game should look a lot uglier but it will not be laggy anymore. You might need to close the Minecraft window for it to actually get better. (laggy wise, not ugly wise). -Hope u find some diamonds.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.