My 2km egg is stuck at 1.37km and when I walk it stays at 1.37km. I have already tried restarting the game but it still doesn't update. How can I fix this?

  • How far have you walked? Sometimes it takes awhile to update.
    – Dragonrage
    Jul 28 '16 at 16:31
  • not sure if coincidence but mine is stuck at 2.37 (notice the .37). walked almost 3km distance isn't adde/ Sep 2 '16 at 16:32

There are two important factors at play here - how and when Pokemon Go calculates distance.

PoGo isn't a fitness tracker - jogging on a treadmill won't do. You have to go outside, and then move slower than 10 miles/hour (18kph). Every few minutes (based on testing, this is around 4 minutes) the game queries the difference between your current position and your position 4 minutes ago, and credits you that distance in a straight line.

So to hatch your egg, walk or bike slowly in a straight line.

  • I've heard talk that simply shaking your device for a while will add distance to your eggs.
    – GnomeSlice
    Jul 28 '16 at 17:06
  • 2
    That is most likely a result of the counter "catching up" with distance you have walked, and people mistaking that as the effect of their shaking.
    – SPavel
    Jul 28 '16 at 17:10
  • What about attaching your smartphone to a ceiling fan and letting it run. Did they fix that or was that just a hoax?
    – Sync
    Jul 28 '16 at 20:00
  • I can't imagine it ever did anything. I know that you occasionally get "free" meters from the GPS wandering around due to poor accuracy at the same time as the distance is captured.
    – SPavel
    Jul 28 '16 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.