2

I am a big fan of Age of Mythology and it worked perfectly on my computer on Windows 7. A few weeks ago I upgraded to Windows 10 and now I get the below error message:

ACCESS DENIED - Please login with administrator privileges and try again

I've already tried a couple of things, but nothing worked for me.

  • I checked if my account is administrator and it is.
  • I tried copying the secdrv.sys file from the CD to system32/drivers -> no solution
  • I tried running it in compatibility mode and then nothing happens.
  • I tried using command prompt to by pass the secdrv security as per this video:
    -> last step was blocked, so I don't know what to do.

Does anyone have a solution to this?

1

1 Answer 1

1

If you have installed Age of Mythology from its original DVD, it might not work with Windows 10. I suggest getting the Steam version instead.

You can also try to update the game using its files, I think there is an updater somewhere in there.

3
  • @Michthan Agreed. But that way, you can get Age of Mythology + Titans + Tale of the Dragon -75% or Microsoft RTS Collection -75% right now! It's Steam Sales!
    – Nato Boram
    Commented Nov 25, 2016 at 7:13
  • Do you know how long it lasts? Maybe I can ask it for Christmas m?
    – Michthan
    Commented Nov 25, 2016 at 7:57
  • 1
    There's no "might", It WILL not work unless you effectively downgrade your system one way or another. "[...] safedisc is a very old technology and is no longer supported. It's not something we can just make compatible on newer versions of windows since no third party is supporting it." – Microsoft Employee Apparently including third party companies owned by Microsoft that, considering the new EE release, are now deincentivised to provide a patch to do so.
    – Mazura
    Commented Nov 25, 2016 at 11:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .