1

So, I downloaded Pokemon Go around July 20th iirc, and it worked more or less fine for a while. The last week or so I had been having problems opening the app while out and about. The other day when this happened I decided to try and see what I could do to fix it. When I went to see if it needed to be updated I got the message that "Your device isn't compatible with this version."

I thought that was kind of strange because I already downloaded the app fine? I checked the requirements and can't seem to figure out why it says it's not compatible?

I've got android version 5.0, and like I said, the app was running more or less fine before. The only thing I can think of is that I don't have enough RAM, but why would it allow me to download it in the first place, then? (And nearly everyone I know in person playing it has under 2GB of RAM)

It was fine for a couple of days, but now when I open the app it says I need to update it to continue playing.

I've been looking around for a fix (or at least a reason) for this problem, but I haven't found anyone with compatibility issues who already had the app downloaded and working.

[edit] I want to stress that the app was already downloaded and working, and that since the update, the system requirements haven't changed.

-1

The explanation: The developers are inept.

The fix:

  1. First make sure you are allowing third party apps.

    Settings>Security>Unknown Sources (Make sure this is checked)

  2. Download the current version of Pokemon Go (0.31.0 at the time of writing) from a SAFE website. (My knowledge of safe vs unsafe is currently limited to this: apkmirror is safe lol)

  3. When it's finished downloading, install it. If you want to wrap up loose ends, turn Unknown Sources back off. (The box we checked earlier)

  4. If you get to a screen that's one solid color when you boot the game up, it's because there are hidden buttons. Somewhere on the screen are two buttons: One that says Accept and one that says Decline. You get to guess where Accept is because someone still had to finish their work and their bosses released the game anyways, but I digress.

edit: I should add that this happened to me as well. This is the second time for me. The first time was resolved by simply waiting about 5 hours or so (and restarting the phone? unsure, but it's always a good idea.) This time I'm unsure, as I'm not sure I want to wait.

Will update.

  • I was trying to avoid downloading an APK, but that seems to be the only fix. :/ I found it on apkmirror and downloaded it smoothly. It seems to be working fine for now. Ah well, I guess it'll have to do. Hopefully things like this will be worked out in the future, I've never had the problem with another game/app. – Sea_Foaming Aug 4 '16 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.