I have the Age of Empires II Gold Edition which contains both Age of Empires II and the Conquerors discs. I have lost the Conquerors disc, so I am trying to play just Age of Empires II. However, on my laptop, if I run the Age of Empires II (not the expansion), it tells me "Please Insert the correct cd rom", despite having the correct CD in. This only occurs on my laptop. On my desktop, the game runs when using the same CD, so it's not a damaged CD.

I have tried uninstalling the game and installing without the Conquerors expansion in case it is trying to launch the expansion pack, but even then it gave the same error.

What could cause this error? Google says it's either a pirated disc (which it isn't) or a damaged disc (which it also isn't since it runs on the other computer). What other issues could cause it?

  • If it's not due to a registry thing, you could try copying the program folder from your desktop over top of the program folder on the laptop and see if that helps. Commented Aug 15, 2011 at 17:43

2 Answers 2


Aside from the obvious cleaning already mentioned, games from the Age of Empires II era had annoying copy protection that relied on putting garbage data in areas of the CD that weren't technically within the CD-ROM specification in question (ISO9660, I think?).

Your optical drive would be asked by the copy protection software to read out the data in these invalid areas to see if it matches what it's supposed to... the idea was that simply copying the files from one CD to another to pirate the game wouldn't bring the purposefully-bad sectors with it.

The major flaw with this plan is that some CD drives are "smart" enough to not bother reading the gibberish or attempt to error-correct it, resulting in a disc that won't validate as genuine, even if it is.


I had an similar issue with my original disc. It was because it was too scratched. It's possible that the drive in your laptop's disk drive (ie. the laser head) is dirty itself as opposed to the disc.

The other thing to ensure, specifically related to AoE2, is to make sure you're running the correct executable. You said you unstalled it but it may have left the old expansion exe/shortcut. Look in your Age of Empires 2 folder in Program Files (I think it was under Program Files\Microsoft Games if I remember correctly) and then make sure you're running the executable in that folder with the red icon. That's the one you want. The Conquerors expansion executable should be in a folder called age2_x1 (again, IIRC). The icon for that will be blue with a helmet on it, I think.

  • @Macha ...if it is the drive (a good indicator is trouble reading backup DVDs), try cleaning the lens carefully with a cotton bud
    – Zommuter
    Commented Oct 14, 2011 at 19:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .