The bar for hatching my egg won't go up. The thing says it is 0.0/5.0, Even though I tried walking around a lot, riding in a car, and riding my bike/scooter. My app is open, but it won't say I've gone anywhere.

What do I do? I have not walked fast, i have actually walked slowly.

  • 9
    Possible duplicate of Does walking fast prevent eggs hatching? – user127650 Aug 7 '16 at 23:05
  • Have you tried rebooting your phone? It usually resolves all my issues with the game. – 0x0000eWan Aug 7 '16 at 23:10
  • yes. but it still does not work. i have also uninstalled it many times – TrainerDoubleX Aug 8 '16 at 0:17
  • Does your GPS show you moving? – Frank Aug 8 '16 at 1:09
  • yes. and i am connected to wifi most of the time too. – TrainerDoubleX Aug 8 '16 at 2:34

As long as your app is working properly, you simply need to walk with the app open. It's more likely to work if you walk outside in a straight line (vs. inside in circles) since it is likely sampling your GPS location every N seconds to determine distance.

Your experience could be caused by the app getting into a semi-frozen state where you can still perform most interactions with the app, but some aspects are broken. Some indications of this I've seen include the animation in the upper-left corner going continuously and images not loading for pokestops.

I'm able to fix by killing the app and restarting. To kill the app in Android, open Settings, select the "Apps" menu, scroll down & select Pokemon Go, then touch "Force Stop". It will warn you that the app may misbehave. Say "Ok", then open the app normally---you should see the Niantic logo initially.

  • well, the pokestop pics are showing. and i have force stopped it, so tomorrow i will try to walk in a straight line. i will get back to you tomorrow afternoon. – TrainerDoubleX Aug 8 '16 at 2:38
  • it seems to b working fine...thx for the help – TrainerDoubleX Aug 9 '16 at 18:09

Niantic was smart making the game as they made a limt of 24 kilometers an hour, otherwise the distance will not count. Thats probably the reason why it doesn't work in cars. ( otherwise it would be too easy hatching eggs. )

You would also need to be walking in a long line, as the GPS Niantic uses is not that accurate, also if that continues, try to restart the game as it is still very laggy.

  • ok. will try today. – TrainerDoubleX Aug 8 '16 at 14:06
  • it seems to b working fine now...thx for the help – TrainerDoubleX Aug 9 '16 at 18:08

Did you put it in the incubator? Most people I know forgot all about the incubator so their eggs won't hatch.

  • yes...but it seems to be working somewhat fine now. thx for all the help – TrainerDoubleX Aug 9 '16 at 18:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.