1

On Battle Net, I am signed in and can see my friends list and such. I also can confirm that I have a good internet connection.

When I launch Overwatch, it loads the game but says "Unable to Connect to Battle Net" and has a big "Login" button underneath. When I click "Login" it then loads again and puts me into the main menu. Although its not a major problem, its still annoying when I minimize the window to do something else and later comeback expecting it to be done loading but its not. I didn't have this problem a week ago as when I launch the game, it puts me straight to the main menu.

Does anyone know how to fix this?

2

You might need to update the game

This have happened several times to me and it is annoying !

The battle.net launcher takes a while to check for updates, I often find myself in the same situation, having launched the game before it notifies me there's an update. And the game doesn't give you a hint about why it can't load.

Launch battle.net, select the overwatch tab and wait a while (generally a minute or two) and if there is an update for the game it will start.

You can also manually search for updates if you open the options menu (under the game title in the tab) and click on "search for update" (my interface is in french so I don't know the exact term, but it is the one above "uninstall the game").

Maybe battle.net notifies you if you chose to let it running after you launch a game, but in my case I chose it to close when I launch a game so I was clueless.

1

Also you can try to repair the game. The option is in the screen of overwatch, just over the play button.

  1. Open battle.net
  2. Go to the game that you want to repair
  3. Go to options menu and select analyze and repair
  4. Choose Initialize analyze
  5. Wait to finish

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.