After looking at the other answers on the site, my issue persists.

I'm using a ZTE Sonata 2, and I registered with a Pokémon Trainer Club account, not a Google account. Yesterday, the game worked as normal. Now it works only when I'm connected to my home wifi. It doesn't work on other wifi hotspots- only our home wifi. I have plenty of data left, which works for any other app.

I can open the game on data or on other wifi. It lets me log in. It brings me to the map and lets me walk around. But no Pokémon appear in the tracker, and there are no gyms or Pokéstops. (There's a gym and two Pokéstops visible from my house with wifi. They're gone when I connect with data.)

If I connect with our home wifi and then switch to data, the Pokéstops and gym are still visible on the map, but can't be used when I go to them, and Pokémon disappear from the tracker. Pokémon do not reappear if I come across a wifi hotspot.

I have looked at various other questions on the site regarding Pokémon Go and data, including the most popular one. (Why can't I connect to Pokemon Go via mobile data?) Every question on the topic seems to be marked as a duplicate of that, but that question didn't help me. Here are a few differences between my question and that one.

A. I can log in from data, I just can't play.

B. I can't play at all on data, even if I start from wifi.

C. Finding another wifi hotspot doesn't help.

D. I'm not using a Google account, I'm using a Pokémon Trainer Club account. (All of the answers on that question related to this.)

E. It wasn't like this yesterday- only today. (The other question technically doesn't state anything contrary, but that's the impression I got.)

I've tried restarting the app and phone both, and also clearing the app data on my phone. None of them helped. I found one question that seemed similar to my issue (https://gaming.stackexchange.com/questions/280084/pokemon-go-cant-see-pokestops-gyms-etc-without-wifi?noredirect=1&lq=1) but it was marked as a duplicate of the former and left unanswered.

  • The game data is not stored on you phone, so clearing your data should be fine. – Dragonrage Aug 10 '16 at 22:57
  • All right, thank you. I just tried it, but the issue is still the same. – Superstars111 Aug 10 '16 at 23:05
  • 1
    +1 for the research you've already done, and the detail you've provided. So many questions about technical problems are painful to read; this one isn't. I wish I had a solution, but hopefully the +1 will help people who might, see your question. – Tim Malone Aug 11 '16 at 0:47
  • So, I just checked again, and it looks like it's working now. But I have no idea why that is. I didn't do anything to it. One possibility I considered was that it was just the Pokémon Go servers being weird, but my little brother (who has the same phone model, data plan, etc.) was able to play on a data connection at the same time that I wasn't, so I imagine it must have been something else. Basically, my question is no longer urgent, but if anyone does know what might have been causing this, I'd still like to know, both for curiosity's sake, and for if it ever happens again. – Superstars111 Aug 11 '16 at 6:29
  • 1
    did you confirm the PTC account with your email address? Because it stops working after 2 days or so if you don't... – Ron Kyle Sep 18 '16 at 18:57

I saw a few questions like these. I did a lot of research myself to see how I could fix the problem, and this trick did it, so I thought I'd add my two cents, and so this can also help future readers.

Why is Pokemon Go not Working on WiFi?

At the first launch of the app, a setting must have been selected automatically that restricts data access to the Pokemon go app.

How to fix the problem

Go to:

  1. Settings of the phone
  2. Go to the apps section of your settings
  3. Click on "reset app preferences" in that section (for my Galaxy S7 I click the three dots at the top right of the screen first)
  4. Launch Pokemon Go

More on resetting app preferences in this article by TechRepublic.


This will reset the app preferences for every app, which means that when you launch an app, it will again ask you a prompt for access to a certain feature on your phone. For example, Gallery will ask for permission to your photos the next time you open it, just like Pokemon Go will ask for permission to your camera.

| improve this answer | |

It sounds like some of the connections you use might be IP banned.

| improve this answer | |
  • 3
    This way your answer doesn't help anyone. More details would be helpful. Why do you think it's an IP ban? Try to prove it. If you can't back it up you should post it as a comment instead. – dly Sep 12 '16 at 6:07
  • From personal experience and other reports. It's the only evidence we, as a community, had at the time. – Josh Sep 28 '16 at 21:19
  • This isn't an answer to the question at all, you need to be able to give a solution to the problem – George Willcox Nov 26 '16 at 10:40

This could be because of a soft ban for too many accounts connecting from the same IP address. Niantic has said they will ban users when using 3 or more accounts from one IP address. I would suggest attempting a ban appeal from your device and see if Niantic un-flags your account.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.