-2

I bought a Quo tablet (chinese one) that has the following specs:

Intel Atom processor z2520 Android 4.4 1GB RAM 8GB ROM 7" 1024x600 res 2MP rear camera

First, when I tried to install Pokemon Go through the google store it would say my device was incompatible, but when I updated everything it let me download it, among other apps that said the same, like candy crush or Battle Camp, so I did, but when I open it, it immediately says "Unfortunately, Pokemon Go has stopped" and never actually opens. This didn't happen with the other apps (candy crush or battle camp, I can use them just fine).

Then, I uninstalled it and re-installed it from the Google Store.. twice, no luck. Then I tried by installing the APK myself and it still won't open..

What can I do to open and use it? And, why is it happening?

Let me add, I don't have any google app installed, since they didn't come with the tablet, could that be an issue?

  • 1
    Perhaps the app isn't lying, and indeed your device is not compatible. 1GB of RAM really isn't enough. – Kaizerwolf Aug 12 '16 at 12:51
  • I've seen people playing with 512mb, also why would play store let me install it the? All other apps run perfectly {including the ones that where incompatible at first) – LuisEgan Aug 14 '16 at 0:27
0

First of all you don't meet the minimum requirements of the game with 1GB of RAM so it may be impossible to make it work on your phone. (at least 2GB of RAM is needed)

Then knowing that :

  • to login into the game you can authenticate using your Google Account
  • Google map are used in the game

You may have to install the Google apps or at least

  • Google System Base
  • Google Android Shared Services
  • Google Maps

But for more stability you shouldn't install those separately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.