1

I keep trying to start my trial/pay for a Realms subscription, but it keeps giving an error saying:

You need permission

You cannot play on Realms because of how your Xbox Live account is set up. This can be changed in your privacy and online safety settings on Xbox.com

Fine. Changed my settings. Allow everything. Still getting the same message. What am I doing wrong??

3

I've just done this for my two kids - it took a while to work out!

I set all the options for Xbox Live for the two accounts to 'Allow Friends'. That wasn't enough. I also had to go to the Xbox One page and check 'Join Multiplayer Games'. Then it worked.

Note that there is a short delay when changing settings online. This may give the impression that it hasn't worked when actually the game simply hasn't rechecked permissions.

4
  • I joined this StackExchange community just to upvote you. Thank you for identifying the combination of Xbox Live settings. I tested several individually to no avail.
    – iangetz
    Jan 2 '19 at 0:28
  • 1
    You said that you went on the Xbox One page, so what is that?
    – Eliot
    Jul 4 '19 at 18:08
  • 1
    Is that the Xbox One page on your (parent) account or on the kids accounts?
    – IanVaughan
    May 1 '20 at 7:57
  • Per what Eliot and IanVaughan said I am having the same problem. There is a page to enable multiplayer and the setting is set to "Allowed" and yet the error still occurs. Can you provide detailed steps on how to get to "the XBox One page" where you check "Join Multiplayer Games".
    – Michael
    Dec 25 '20 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.