8

Specs: Mac book air, os x 10.8.5 Since the update at 08/16/16, my friends list got buggy so I decided to do a fresh reinstall, I backed up my steamapps folder, deleted it from applications and library and reinstalled (Note that steam runs on a seperate non-case sensitive partition). But now it's just stuck on this window and won't change. I tried reinstalling like three times and no avail. Any help?

enter image description here

  • According to Steam's website, OSX 10.7 (Lion) is the minimum requirement, so that's not the issue here. Regardless, have you thought about upgrading to Yosemite or El Capitan? That could potentially resolve the issue, as extreme as it is. – Kaizerwolf Aug 19 '16 at 13:28
  • Yeah at first I thought that was the exact issue, and might be, since valve might've just taken a bit to change the system requirements. But the internet I'm currently stuck with here in Brazil is roughly 750kb so updating would take almost a week, that's if the internet doesn't fall (Which is something it does frequently). Thanks for the advice though. – JuliusdaTiger Aug 19 '16 at 15:05
  • Ah yes, that can be a slight pain in the butt. 5 gigs of El Capitan on unreliable 750kb/s isn't so great. – Kaizerwolf Aug 19 '16 at 15:06
  • 1
    Any luck sorting this out? I have the same issue on OSX 10.11 (El Capitan). Installed 3 times, removed the Library folder and all app cache directories. No idea what is going on here! – Ahi Tuna Jan 26 '17 at 21:50
3

This most likely has to do with using a case-sensitive filesystem on MacOS. Steam is unable to locate the correct resources for the login window, locales and so forth.

Verify that this is the case by opening Disk Utility or execute the following command in your Terminal:

diskutil info / | grep -A2 Personality

-
File System Personality:  Case-sensitive Journaled HFS+
Type (Bundle):            hfs
Name (User Visible):      Mac OS Extended (Case-sensitive, Journaled)

You will need to rename resource files (*.res, *.tga) to lowercase; these are located at:

/Users/$(whoami)/Library/Application\ Support/Steam/Steam.AppBundle/Steam/Contents/MacOS/public
/Users/$(whoami)/Library/Application\ Support/Steam/Steam.AppBundle/Steam/Contents/MacOS/steam/cached/
/Users/$(whoami)/Library/Application\ Support/Steam/Steam.AppBundle/Steam/Contents/MacOS/friends
/Users/$(whoami)/Library/Application\ Support/Steam/Steam.AppBundle/Steam/Contents/MacOS/graphics
/Users/$(whoami)/Library/Application\ Support/Steam/Steam.AppBundle/Steam/Contents/MacOS/servers

Asturaz apparently already brewed up a small script to automate this, located here: http://steamcommunity.com/discussions/forum/2/282992646978253149/#c282992646985999495

| improve this answer | |
-1

Have you tried deleting the stuff that remains after a uninstall ? if it's like windows there are always some leftovers of a previous software, most of the time they are configuration files. those might cause your problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.