My friend is having a really annoying problem with his minecraft but he doesn't have a SE account so I thought I'd ask this for him: Whenever he tries to log onto a server he gets this message:

java.lang.NullPointerException group.  

We have tried:

  • Reinstalling minecraft(including the .minecraft folder),

  • Reinstalling java,

  • Eradicating everything java related on his PC,

  • Disabling his antivirus,

  • Flushing the DNS cache,

  • signing off and signing in to minecraft,

  • Restarting his PC,

  • Raging :(

How can we fix this?

  • 2
    What exactly does the NullPointerException state? Please post the stack trace.
    – dly
    Commented Aug 22, 2016 at 7:20
  • Have you tried changing the launcher viability? Commented Aug 22, 2016 at 10:26
  • everything is ok. My friend uninstalled his antivirus completely, it seems to be a common problem with avast users.
    – user134783
    Commented Sep 6, 2016 at 1:59
  • 1
    For people in the future, getting rid of your antivirus shouldnt be the solution, if you need to you should be able to add it to the "allowed" programs
    – Penguin
    Commented Jan 20, 2021 at 15:45

4 Answers 4


Your problem is already fixed probably, but for the people who are searching for a fix, follow my steps

  1. Search for CMD and run it as administrator
  2. Type in the bar: netsh winsock reset
  3. It should be fixed!
  4. If it still doesn't work, try contacting Mojang, the creators of Minecraft

If you are playing newer snapshots, This was a recent bug in the 17w14-16

They seem to have finally fixed it in 17w17a/b

It seemed to be related to a number of new additions like advancements and parrots.

Update your server_jar and your minecraft client to 17w17b (current)

If you are getting this issue on 1.11.2 release. Then open a bug report at bugs.mojang.com


This works for real. My friends and I have tried this and it worked. now i can play Minecraft no problem. So try this. If Minecraft has the dull error go to your folder. press minecraft installer. Press repair and finish let it redo that. Then go to launch options and delete all the modes that are the same. like The latest release and there is a 1.12.2 . Delete that 1.12.2 . Please try this it worked for me and my friends I hope it does for you!


This happened for me too, i realized that i was using the Public IP Adress, you must use the IPV4 Adress, that can be found by typing "ipconfig" to CMD. Hope this Helps!

You must log in to answer this question.