Upon realizing that coconuts could be thrown, I threw one, it hit the wall and it's contents spilled out all over my floor:

coconut stained floor

How can I remove this?

I have tried using the matter manipulator with the fluid upgrade, but I think it doesn't work because there is the teleporter there.

Reloading the game/server doesn't change anything.

  • Try using Shift + Click using the Matter Manipulator so that it picks up the single square of liquid instead of the Teleporter (which the MM will try to pick up first since it's solid) Commented Aug 23, 2016 at 7:52
  • No luck on that
    – Aequitas
    Commented Aug 23, 2016 at 8:08
  • 1
    Try to break background wall behind the milk. It should act like a drain. Commented Aug 24, 2016 at 10:32
  • @HolyBlackCat can't breakthe wall of the ship
    – Aequitas
    Commented Aug 25, 2016 at 0:45

3 Answers 3


This is unfortunately going to be a roundabout solution that requires a little work, but the best way to fix this would be to upgrade your ship.

Based on your screenshot, you've still got the tier 1 space ship, which has the pilot's seat area, a small amount of storage space, and the teleporter. If you upgrade to the second tier, a new room will be added behind the teleporter. Remove the barricade from the new room, and the water should flow in (and probably disappear since it doesn't look like there's enough there to cover the floor of the new room).

To upgrade your ship, you need to either recruit two crew members (by doing quests for NPCs in any town, who will then occasionally decide to join you) or you can buy the "Fake Kestral License" from the Penguin Bay, then bring the license to Pete (far right in the Outpost). It does require a handful of upgrade modules (which are pretty common).

  • 1
    You also need some Upgrade Modules to complete the upgrade, regardless of whether maxed out your crew or bought the fake license Commented Aug 23, 2016 at 14:22
  • This is the correct answer. I ran into a similar problem a few days ago (had to flood my ship with lava due to a bug that caused my whole crew to duplicate itself) and ended up with some lava stuck in the teleporter just like that. The only way to get rid of it is to upgrade the ship until the space between the teleporter and the wall opens up, and then the water spreads out and disappears.
    – nasukkin
    Commented Aug 26, 2016 at 19:06

I had a little free time and came up with a solution, it's really simple as you can see all you have to do is remove a background block with the right click, and the coconut oil will drain into space.

enter image description here

  • How did you break the background wall, I tried it and it doesn't work
    – Aequitas
    Commented Aug 30, 2016 at 23:51
  • @Aequitas Simply hold right click, It doesn't work for you ? That's weird. Maybe we are in different version ? I'm in 1.0.5 (windows x86_64), what your version ?
    – Paul
    Commented Aug 31, 2016 at 0:02
  • will look and try again
    – Aequitas
    Commented Aug 31, 2016 at 3:10

This answer does not help in this exact situation because the teleporter is in the way and you cannot put a drain over the teleporter.

What you need to do, is drain it, with a drain !

gurgle, gurgle

You can craft at the Wiring Station.

If you don't have access to it, then you can possibly find one in an Apex Test Facility or in any Hylotl Underwater City. The underwater cities are usually easier to find, jut go to an ocean planet, find the underwater city, turn of the generator and then you can pick up a few at the airlock at the far ends of the city. Just make sure to left some otherwise the airlock might malfunction.

  • I haven't yet unlocked it but if I understand it correctly it won't work as I won't be able to place it, since the teleporter is there and I can't place something on top of it
    – Aequitas
    Commented Aug 23, 2016 at 12:26
  • Tested it using admin commands, doesn't work as I can't place it.
    – Aequitas
    Commented Aug 23, 2016 at 12:28
  • Indeed. In modern version of Starbound you can't build around the ship teleporter.
    – Nakilon
    Commented Aug 23, 2016 at 12:55
  • @Aequitas You guys are right, when I posted this answer I didn't realized that the teleporter would be in the way but I had a little free time and came up with a solution, I will post it in an another answer
    – Paul
    Commented Aug 30, 2016 at 23:05
  • @Paul: If you're just going to strike-out your answer, you might as well delete it. It's very difficult to read in this state. Or... update it with your new answer instead of posting a new answer.
    – Ellesedil
    Commented Aug 30, 2016 at 23:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .