-2

I'm making a texture pack for Minecraft 1.9. While I was working on on the pack, 1.10 came out. Back when it was 1.9, there was a bug where it said it was incompatible, when my texture pack was made for 1.9. So, when it said "incompatible" in 1.10, it ignored it, since it still seemed to have no bugs in 1.10, so I kept re-texturing. Later, I started working on andesite, and it showed that purple and black checker pattern that happens when it doesn't know the texture of that block or item. I double checked, and it was the right type of file, right name, right everything, but it still shows that texture. I don't want to have to redo the entire texture pack in 1.10, just so this will happen again when 1.11 comes out. Any tips on how to fix this bug? (BTW, I've re-textured other blocks since this happened, and it seems to only have happened with the andesite.)

closed as too broad by Wrigglenite, Frank, GodEmperorDune, angussidney, MrLemon Aug 30 '16 at 10:07

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Telling us everything is right isn't particularly useful, as this wouldn't be happening if everything was right. Could you upload some screenshots of your resource pack folders, or upload the resource pack? – SirBenet Aug 29 '16 at 18:39
  • I'm afraid not. I don't know how to upload files like that, and it weirds me out too. This shouldn't be happening. I don't know why it is. Could you maybe tell me step by step what I should've done when saving, just in case I may have done something wrong. Btw, I'm using a Windows 10 computer, with Adobe Photoshop to re-texture. – MC help Aug 29 '16 at 18:43
  • There's a lot of things that could have gone wrong. Try dragging the resource pack folder into Google Drive (google.com/drive). Once it's uploaded in Google drive, right click and select Get shareable link, then paste that here. – SirBenet Aug 29 '16 at 18:46
  • I already told you, even if I could, I'm not going to upload anything. I already have accidentally almost broken a computer before. I'm not doing anything I don't know how to do well. – MC help Aug 29 '16 at 18:49
2

The above is known as the Missing Texture texture. It shows when a block does not have a valid texture in the current resource pack.

In order to fix this, ensure the following:

  • The texture exists in ANY resource pack
  • The texture has an even horizontal and vertical size
  • The texture is a valid image

If any of these is invalid, the above block will show instead.

From the Wiki:

For block or item textures to function, they must have equal width and height (or height that is a multiple of the width if animated); otherwise it will display as a purple and black checkerboard. For most other textures, the file will simply be stretched to fit the required dimensions.

Most solid blocks will turn any transparent area fully opaque. The rest of the blocks, along with most entity textures will allow clear areas of the texture. All items and any blocks or entities which are semi-transparent by default support semi-transparency.

If a file does not exist in any resource pack, including the default, it will display as a purple and black checkerboard.

  • Thank you Kaz Wolfie. That is the texture that is being displayed. I know this is a texture the exists in any resource pack, and it is a valid image, so I will check the image size, and I will get back to you. Thank you. – MC help Aug 29 '16 at 20:27
  • I just checked. I meant to make the size 106 by 106 pixels. It was accidentally 106 by 107. Thank you. – MC help Aug 29 '16 at 20:28
  • If this solved your problem, hit the grey checkmark! it marks the question as solved and gives you some valuable rep. Be sure it works in game first though. – Kaz Wolfe Aug 29 '16 at 20:30
  • I just saved and... IT WORKS NOW!!!!!!!!!!!!!!!! Thank you, very, very, much. – MC help Aug 29 '16 at 20:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.