1

When I start Starbound the window asking to launch client or server pops up and when I answer client, the sidebar says "Running" then flashes "Syncing" then nothing. When Steam is launched from terminal, this is outputted:

Game update: AppID 211820 "Starbound", ProcID 28390, IP 0.0.0.0:0
ERROR: ld.so: object '/home/mitchell/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/mitchell/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/mitchell/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/mitchell/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
[Info] Application: Initializing SDL
[Info] Application: startup...
[Info] Root: Preparing Root...
[Info] Root: Done preparing Root.
[Info] Client Version 1.0.5 (linux x86_64) Source ID: 7d4a2bbba04d43bd7f43f0ca940db23b2187edc1 Protocol: 724
[Info] Root: Scanning for asset sources in directory '../assets/'
[Info] Root: Scanning for asset sources in directory '../mods/'
[Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
[Info] Root: Detected asset source named 'base' at '../assets/packed.pak'
[Info] Root: Detected unnamed asset source at '../assets/user'
[Info] Loading assets from: '../assets/packed.pak'
[Info] Loading assets from: '../assets/user'
Generating new string page texture 113: 8x256, total string texture memory is 4.61 MB
[Info] Assets digest is 835de2a06240fd303c5cfc854388f3b67407dac8e006f903343715672b0705a3
[Info] Root: Loaded Assets in 0.673758 seconds
[Info] Application: Initializing SDL Video
libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
[Error] Fatal Error: Segfault Encountered!
./starbound(_ZN4Star10fatalErrorEPKcb+0x43) [0xa11063]
/lib/x86_64-linux-gnu/libc.so.6(+0x354a0) [0x7f62df4564a0]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x12960) [0x7f62dff11960]
/home/mitchell/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libX11.so.6(_XError+0x126) [0x7f62dd78e206]
/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1(glXMakeCurrentReadSGI+0x1b2) [0x7f62e036a4d2]
/home/mitchell/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0(+0xbc978) [0x7f62e08e9978]
/home/mitchell/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0(+0xbcc96) [0x7f62e08e9c96]
/home/mitchell/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0(+0xaede0) [0x7f62e08dbde0]
/home/mitchell/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0(+0xafc84) [0x7f62e08dcc84]
/home/mitchell/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0(+0x1744f) [0x7f62e084444f]
./starbound(_ZN4Star11SdlPlatformC2ESt10unique_ptrINS_11ApplicationESt14default_deleteIS2_EENS_10StringListE+0x1b8) [0x1224048]
./starbound(_ZN4Star18runMainApplicationESt10unique_ptrINS_11ApplicationESt14default_deleteIS1_EENS_10StringListE+0x3f) [0x12217af]
./starbound(main+0x457) [0x8e85f7]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7f62df441830]
./starbound() [0x8f59fc]
Aborted (core dumped)
Game removed: AppID 211820 "Starbound", ProcID 28390 
No cached sticky mapping in ActivateActionSet.Generating new string page     texture 115: 256x256, total string texture memory is 393.22 KB

I have tried everything I have found. My system certainly meets specifications, and I am running Ubuntu 16.04 LTS. The odd part is that if I choose to run the server, everything works (note: I haven't had somebody try to connect), and if I run using run-starbound.sh everything works fine as well. This makes me think there is a problem with Steam, not Starbound.

Thanks in advance for the help.

  • Try searching for specific errors in that data log, like LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32) or libGL error: unable to load driver: nouveau_dri.so – wcarhart Sep 2 '16 at 4:40
  • Mass posting error logs with little or no research effort is unlikely to get attention here. Try to narrow down your question a bit – wcarhart Sep 2 '16 at 4:40
  • @ThePickleTickler thanks for the hint about noveau... I was resarching segfault and coming up empty. – Mitchell Sep 3 '16 at 13:31
1

The problem is with libstdc++.so.6 this can be fixed by preloading it when launching steam. This command should be used when launching steam.
LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam

To make this easier put that command in a bash script of some kind.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.