4

a friend and I usually play Minecraft together on LAN worlds. Everything works perfectly if we direct connect by typing in the local IP address as well as the port. This is okay usually, since when you open a LAN world a message pops up that tells you the port. We tell each other the port and direct connect using the IP and port. The games do not show up in the multiplayer screen under Scanning for games on your local network

I have added Minecraft and JavaApplicationStub to allow incoming connections in my Mac firewall.

It is annoying to have to type in the IP and port every time we want to play. Also, we are trying a new mod and when we open the world to LAN, there is no message that tells the port. Is there a way I can get these games to appear when scanning for multiplayer games? We are both on Mac OS X.

  • Check for Windows Firewall issues. I ran into this once while playing with one of my kids on a LAN game. – Tim S. Sep 9 '16 at 19:56
6
+25

So I've done some testing on my side on a Windows machine, and this should be the same on all systems from what I've seen online.

I've setup two machines, with Minecraft on both PCs. I've also installed TPCView on both machines to view the network connections they create and leave open. What I've found that is Minecraft does not use it's own PID when making a network connection, but instead has Java handle the network calls.

Screenshot of Java Network calls

From my personal PC, Java opens and connects with 6010-6127 onto a process locally. (Most likely this is to the Minecraft Process, except the red one which is Amazon's cloud services) When I click into the Multiplayer tab, we get four new connections, but two of them (UDP 4445) are left open:

Screenshot of Java Network calls while searching the network

I've tested this on the other PC, with the same outcome. four new connections, two of them matches the port that the game reports (60xx), and the other two are UDP 4445 left unconnected.

On searching about this, I've found a post from 2012 about a plugin author making an app to make local worlds announce themselves as LAN worlds using the same UDP 4445 "Announce" port. I would have to believe that this port (UDP 4445) is the one that is being blocked from allowing the game to announce it self as a "open server" locally.

3

I have gotten this problem before, and it's very easy to work around.

  1. Open your LAN world.
  2. Windows: Open Start and type CMD. Open the top result.
  3. Mac: Open up Spotlight Search and type Terminal. Open it.
  4. Windows: Type "ipconfig" in the box and hit enter. Look for something that says "IPv4 Address". Remember the sequence of numbers after that.
  5. Mac: In Terminal, look for something called wlan0 (for Wi-Fi) or eth0 (for wired Ethernet). Below that, you should see something like "inet addr:" and then a sequence of numbers. Remember that sequence.
  6. Now, go onto the computer you want to join the LAN world from. In Minecraft, open Multiplayer and select "Direct Connect". In that box, type the IP address I told you to remember earlier.
  7. Go back to the other computer and open chat. Find the line that says "Local game hosted on port XXXXX". Remember that port number.

  8. On the computer with Direct Connect open, type a : (colon) and put the port number after it. Now just hit Connect.

    That's it! You're done!



    Edit: I just realized your post said "I don't want to type in the IP every time". Whoops...

  • Do you k ow how to find the port without using Minecraft? When I open it to LAN it doesn't say a port, which is the main problem – Griffen Sep 14 '16 at 4:15
1

You should be able to open a world to LAN using Options and have your friend join the game through the select-game menu.

In a world: Esc - Open to LAN

To join it: Title Screen - Multiplayer - Your World!

Edit: If your game will not accept incoming LAN wireless games, consider reinstalling Minecraft.

  • 1
    One player hits Esc -> Open to LAN and usually a message pops up that shows the port. From there we can use the direct connect button and type in the IP and the port and it works. It just doesn't appear in the list on the Multiplayer screen. It is impossible to figure out the port when the message does not appear telling us the port. – Griffen Sep 7 '16 at 5:50
  • @水口玄造, you should be able to view the port number after you open the server by hitting the 't' key to open the chat window. 'esc' will close the chat window. – kevlarjacket Sep 9 '16 at 14:14
  • The question describes how the user usually plays multiplayer with no problem. He knows how to join a multiplayer game. Possibly the problem is to do with firewall settings, in which case reinstalling minecraft will have no effect. – Jonathan Hartley Jun 30 at 13:21
0

You just write localhost in Direct Connect and it connects to the ip and port automatically.

  • 1
    Looking at the other answers, I feel the issue is deeper than that. What you say could work, but it may also result in the same issue. – Timmy Jim Aug 16 '17 at 18:26
0

Running a Minecraft server On Windows 10, LAN clients couldn't see it.

Fixed by opening Windows settings, search for "Firewall and network protection".

On that dialog, click "Allow an app through firewall"

On that dialog, find the entries for "Java(TM) Platform SE binary". There are many, I presume for all the historical versions of Java that have been installed in the past.

Click the 'change settings' button to enable the controls, and then for every "Java" entry, I checked both the 'public' and 'private' checkboxes. I have no idea what I'm doing, but that made minecraft work. No reboots or restarts were required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.