6

I play almost exclusively using a HOTAS and an Oculus Rift, and I'm having an impossibly difficult time with the navigation system in that environment. Specifically, it's nearly impossible to select a star system from the galaxy map.

I can navigate about just fine using the joystick, or using the keyboard and mouse, but none of the stick bindings seem to select a system, so I have to default back to keyboard and mouse.

Keyboard and mouse are basically useless because the mouse cursor is drawn on a 2D plane in front of the 3D map, and neither eye's view of the cursor actually matches where a click will occur. I spend so much time hovering my mouse around each star trying desperately to find the magical spot that will actually let me click the thing.

Surely there is some way to reliably navigate that doesn't require me to change my graphics settings and remove the Rift... right?

  • 1
    At this point I find it easier to set up bookmarks out of VR and then switch over to the HMD and just use those. – Richard Benson Sep 8 '16 at 11:06
  • 1
    Aside from this issue, i am very jealous of you, sir. Must be a great game for the Rift. – Dpeif Sep 8 '16 at 17:20
  • It is actually a pretty great game for the Rift, with one caveat besides the map problems above - the limited resolution of the Rift makes reading the small text scattered liberally about the game's UI quite difficult. This is exacerbated by the fact that I only have a DK2, which is even less ideal than the consumer Rift for that purpose. – David Perry Sep 12 '16 at 17:23
2

Despite all best efforts, nothing suggested actually worked, but that's OK because the problem itself was fixed in the recent 2.2 update. All of the maps just plain work in VR now.

| improve this answer | |
  • 1
    Oh, this is EXACTLY what I wanted to hear that it now works in 2.2 Started googling this during the upgrade and will have a go at it right now. Your last sentence was the most useful tip I found anywhere ;-) – Boris Nov 4 '16 at 21:16
  • Do they "just work"? The mouse doesn't work, none of the default bindings on a HOTAS seem to do anything. None of the answers are specific on how to actually use this thing... – hughes Oct 14 '17 at 6:07
1

Surely there is some way to reliably navigate that doesn't require me to change my graphics settings and remove the Rift

You could perhaps use the keyboard to search by name (second tab in left-side menu). That moves focus to the named system and brings up the submenu for that system.

Disclaimer: I don't have Oculus Rift so cannot verify the usability of the above.


To be able to use the UI navigation keys in the Galaxy map, you must remap the keyboard controls so that the Galaxy Cam controls do not use the same keys as the UI controls.

For example, these are the normal Interface Mode controls:

enter image description here

If you open the Galaxy Map submenu, you'll see it also has WSADEQ mapped. I changed this as follows

enter image description here

I was then able to use the "D" key using keyboard alone (no mouse etc) to move focus to the submenu for the highlighted star system (after using the search option) - and move across Select/Route/Bookmark/System/... You can use spacebar to select the menu-item (e.g. to open system map).


Here's an example in detail

enter preformatted text here
ESpaceNANTER enter image description here
Enter enter image description here
QQ enter image description here
Space enter image description here

Voila - route plotted

| improve this answer | |
  • It does move to the named system, but does not bring up the submenu. I find that even when searching for systems in this way I still must zoom all the way in, then pan and rotate around, clicking dozens of times off to the sides of the system until I find the magic spot that brings up the submenu. And then, half the time, it still ends up selecting the system next door... – David Perry Sep 12 '16 at 17:21
  • @DavidPerry: See updated answer for possible solution for submenu navigation. – RedGrittyBrick Sep 12 '16 at 18:17
  • Awesome! I will be trying this out as soon as I get home from work. – David Perry Sep 12 '16 at 18:25
  • Yeah, no, still doesn't work, because for some reason when you search for a system it automatically brings up that system's submenu and it doesn't do that on my system. I've scoured settings and can find nothing that changes this behavior. – David Perry Oct 22 '16 at 2:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.