2

Ok so I have a Bukkit server up and running and I want to use the Permissions Plugin to help give different users different permissions to help protect the server. I configured the permissions and reloaded them. However it seems that users have access to commands that they should not be able to run. Here is my set up...

Groups.yml

groups:
    Default:
        default: true
        info:
            build: false
        permissions:
    Builder:
        default: false
        info:
            build: true
        permissions:
            - 'worldedit.*'
            - 'mobSpawner.*'
            inheritance:
            - Default
    Moderator:
        default: false
        info:
            prefix: '&b'
            suffix: '&f'
            build: true
        inheritance:
            - Builder
        permissions:
            - 'worldedit.*'
            - 'motd.*'
            - 'worldguard.*'
    Admin:
        default: false
        info:
            prefix: '&4'
            suffix: '&f'
            build: true
        permissions:
            - '*'

Users.yml

users:
    test_user:
        groups:
        - Builder
        permissions:
    admin_user:
        permissions:
        groups:
        - Admin

When I run the /pr test_user perms listall command it outputs worldedit.*, mobSpawner.* which means that the permissions are being loaded correctly. But when I log on as test_user I am able to use the /regions command which is a part of WorldGuard plugin which the test_user should not have access to. What am I doing wrong?

3
  • 3
    Is your character name registered as an OP on the server? From my experience, OP status instantly gives permissions to all commands, even if the user isn't in a group that allows the '*' permission.
    – Kevin Yap
    Aug 23, 2011 at 3:51
  • Along with what Kevin Y said, I've found that worlds that aren't called the default name (world) don't accept permissions until permissions are setup for a world called "world". YMMV.
    – Kurley
    Aug 23, 2011 at 10:35
  • @Kevin Y That was it! Thank you can you submit an answer so I can mark it as correct. Thanks again. Aug 24, 2011 at 11:36

1 Answer 1

4

Your problem may be that you are an OP on your server. I had this problem when setting up one a server – OPs seem to have permissions to access all commands (the * permission node), even if Essentials is trying to override it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .