6

This question already has an answer here:

This is only since the new update 0.37.0

I have been playing since the game came out in the UK and have got a Moto G phone

I log on using google accounts. I dont really want to start again as I have 104 different pokemon.

I can play fine on wifi, but can not connect on my mobile data. I have uninstalled the app and then reinstalled it, it didn't work, I logged in and out a few times to test it, and then I restarted my phone and the same thing again, the bar loads 1 bar and then comes up saying sign out.

marked as duplicate by Vemonus, Schism, Dragonrage, Wrigglenite, Timmy Jim Apr 21 '17 at 22:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

10

Exact same issue here, and I am also using Moto G too.

I've put the issue into Niantic's online bug submission but I reckon that will lead to a long wait for answers.

ANSWER - confirmed on my Moto G

Settings > Data Usage

In the 'App Usage' section, click on Pokemon Go and ensure that 'Restrict app background data' is set to OFF (slider should be grey)

Do the same for 'Google Services' and 'Google Play Store'

All three of these apps should be unrestricted.

Now PoGo should work on Mobile Data...turn off Wi-Fi to test.

  • 2
    @Sumurai8 he may have said he is having the same issue, but he also provided a potential solution. – MattR Sep 15 '16 at 12:56
  • 2
    @Mattr I commented (and flagged) before they made a substantial edit to their post, adding in the answer. Before it only stated they had the same problem, and posted the same question on Niantic's support platform, which did not answer the question in any way, shape or form. See the edit history for more details. – Sumurai8 Sep 15 '16 at 14:04
  • Same problem with an HTC Desire. I think the problem is more generalized that it may seem. In any casr. Thanks a lot. – Karlyr Sep 16 '16 at 15:05
1

In addition to момокоs answer (i am not allowed to add comments yet), check the apps permissions on your phone. Since Android 5 i think you are able to block some/all of them. Maybe you disabled something needed by default.

0

Take note of the following:

  1. Is your phone's GPS turned on?
  2. Has your mobile internet subscription run out?
  3. Maybe your mobile data is restricted. Try and change that in the settings.
0

I also had this problem, I had checked the 'Restrict Background' option and it was off. What fixed it for me was getting a friend to open up a wifi tether for me and then I connected to that. After that I could then connect to my 3g again with no problem.

I then dropped my phone down the stairs so it dosent work again now.. but it fixed it until my clumsiness got the better of me :)

0

I had the same problem. What solved it for me was that I logged on with the wifi at home and minimized pokemon go app. I then went to the apps on my setting and did a forced stop on pokemon go app. I reopened pokemon go on my wifi and turned off my wifi, after which my pokemon go worked with my data.

-1

Do you have root access to your phone?

One of the last updates blocked users with root access cause you could fake your GPS position.

Not the answer you're looking for? Browse other questions tagged or ask your own question.