Recently I've been messing around with making a few minigames, and have used a few plugins to help make it easier to create and run them. However, a newer one I'm making requires me to use the /summon command in order to spawn zombies. However, no matter what I put in, I can't spawn hostile mobs. All other entities still spawn perfectly fine. Strangely, the /spawnmob command which comes with Essentials can summon hostile mobs fine. I would rather use /summon since it's more customizable though. Here's a list of plugins I have installed.

  • Essentials
  • EssentialsChat
  • HolographicDisplays
  • PermissionsEx
  • setspawn
  • [A plugin I have made, just a simple timer]
  • Vault
  • VoxelSniper
  • WorldEdit
  • WorldGuard

Please let me know if you have any ideas on what I'm doing incorrectly or isn't functioning the way it should.

  • Does WorldGuard prevent mobs from spawning? /summon won't work in regions with mob spawn denied.
    – dly
    Commented Sep 20, 2016 at 8:18

2 Answers 2


I believe that Essentials overrides the /summon command.

To circumvent this, you can either do this in the bukkit.yml, or use a different command.

The command to override it is /minecraft:summon then the arguments as per normal. This works for other overridden commands, like /minecraft:give, if you prefer the default syntax/arguments.

  • 1
    I have just attempted this, bukkit:minecraft just says "unknown command" while minecraft:summon results in the same error (Username: Unable to summon object) Note: I've made sure to use the correct formatting at casing for the command, which seems to be the issue for most other players.
    – Thane
    Commented Sep 17, 2016 at 22:16
  • @Thane Could you give an example of a command you've tried using, and I can see if I can fix it.
    – Oliver
    Commented Sep 17, 2016 at 22:26
  • 1
    /summon Zombie; /minecraft:summon Zombie; /bukkit:summon Zombie EDIT: I've gone into the server.properties and commented out the spawn-monsters=true option. After rebooting the server the properties uncommented it, but somehow the issue is fixed. No idea why this fixed it, but it did.
    – Thane
    Commented Sep 18, 2016 at 2:15
  • Essentials should support /summon just fine, since it's using /s for summoning players to you (alias /tphere).
    – dly
    Commented Sep 20, 2016 at 8:14

You have to include the coordinates!

Since you are using Essentials, I believe you have to do: /minecraft:summon (mob) ~ ~ ~

You can replace the ~s with coordinates or leave it as it is to summon a mob right at the location where it's being summoned.

  • /summon works with Essentials.
    – dly
    Commented Sep 20, 2016 at 8:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .