2

I've killed many dragons in Skyrim. But whenever I kill one, it never gives me their soul. I've been playing on the missions with Miraak and to complete a mission I need to use a shout. But I can't, because I have no dragon souls. Is there any way to fix this?

I've looked here and this didn't help me. Why can't I absorb a dragon soul?

I'm playing on a PC with no mods.

  • Are you on PC or a console? Do you have any mods? Have you tried the suggestions on that page? How much of the main quest have you done? Did you fight that dragon at the western watchtower near Whiterun? – Lord Harkon Sep 17 '16 at 19:50
  • Im playing on a pc.. no mods.. In the main quest i just did the stuff with areingar. and on the westwern tower i used a setstage command. – Tom Ribbertry Sep 17 '16 at 19:57
  • and no unoffical patches. i play on legendary edition so i have all the dlc – Tom Ribbertry Sep 17 '16 at 19:59
  • 1
    Did you use a setstage command at the western watchtower because you were unable to absorb the dragon’s soul, or because you just wanted to finish it faster? – Lord Harkon Sep 17 '16 at 20:14
  • 1
    I would try installing USLEEP, and use the load order they give. I haven't been able to figure out a console command to enable absorbing dragon souls, but you could use player.modav dragonsouls 3 (or whatever number) to give yourself some souls. – Lord Harkon Sep 17 '16 at 21:19
1

You mentioned that you have been doing missions with Miraak, which is part of the Dragonborn DLC. After reaching a certain point in the DLC, you will not be able to gain dragon souls from dragons as this is important to the DLC's story. You must complete the questline to be able to acquire dragon souls again.

  • but i didnt evan recive the soul from the first time i fought a dragon in whiterun. – Tom Ribbertry Sep 17 '16 at 19:58
  • i didnt evan start the mirak mission intell weeks after – Tom Ribbertry Sep 17 '16 at 19:58
  • But you have started it now? If you can complete the DLC storyline, you might be able to acquire dragon souls again. Otherwise, you might need to resort to console commands. – Yuuki Sep 17 '16 at 20:08
  • i tried finishing the dragonborn quest but at the end mirrak cant aborb the souls.. – Tom Ribbertry Sep 30 '16 at 4:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.