1

In light of asking this question in the Meta section of Arqade, I've decided to go ahead and ask this question.

My friend and I have recently purchased 7 Days to Die on Xbox One. We would really like to take advantage of the multiplayer, but we are having difficulties trying to.

If I host a private game, and invite my friend to join, every time he attempts to join, the game says "Waiting on Server" until it eventually gives the error "Failed to Connect to Server."

If I host a public game, he gets passed the "Waiting on Server" message, and the games says "Starting Game." He can hear some sound effects like birds chirping in the background and various other noises, but eventually he will get a message saying he was removed from the game.

If my friend hosts a private game or public game, I can connect and we can play, however I am extremely limited in what I can do. I can't for some reason interact with campfires or search cars, garbage, etc. If I build a house or some other structure, leave the game after some time and come back, the structure is gone. My skills don't save either. Worse yet, I'm restricted on where I can walk, as the map refuses to render nearly everywhere except where I spawned.

There have been times, where my friend and I have been able to meet up in the game (he had to run very far to me as my map wouldn't load much) and we could play normally for about 5 minutes. Eventually, my friend would ask me why I wasn't moving, to which I would reply that I was moving. Whenever this occurred, I lost my ability to interact with objects, and whatever structures I built would only be visible for me. I was still moving around on my screen, but not on his. If I quit the game and rejoined, my friend could see me move again and I could play normally, but all my progress and anything I made during my "frozen" state was gone.


What I have tried so far is some port forwarding on my network, but I don't think that really helped. I've changed my character as this post suggested, as I was playing as Clint (I've read elsewhere that apparently him and Miguel are somehow glitched) but that didn't work. I've read on another post that clearing the Xbox's persistent storage under the Blu-Ray settings fixed the issue for one person, but it had no effect for us.

Has anyone had any luck resolving this issue? From what I can gather we are not the only ones that are experiencing these difficulties.

The Current game version is 1.0.11.0. My friend and my NAT type is Open.

  • What you describe when connected to your friends game sounds like a really poor host, I'd test your friends upload speed. – Aequitas Sep 21 '16 at 13:45
  • @Aequitas His upload is around ~.7-1mbs. Mine is around ~10-12mbs. – Timmy Jim Sep 21 '16 at 14:45
-2

I ran very far away, left my friends game, joined my private game, opened a chest and left that game. My friend reloaded his game I joined and ran back and now I can open chests I don't know which one of those did it but now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.