3

I'm building a map and I'm trying to teleport a Armor Stand named Jacob, but it tells me:

'888ba526-c645-4271-8ca7-5bf8cca13344' is not a valid number

Here is the command:

/tp @e[name=Jacob] -459.1 202.0 -840.4

I'm using minecraft 1.10.2. I have no mods installed.

Here is a screenshot:

enter image description here

13
  • Wouldn't you need to make it target an armor stand in []? Also, please include a screenshot and the version you're using, and if your using mods Sep 20, 2016 at 23:07
  • Alright Alex, i added in more info
    – user166129
    Sep 20, 2016 at 23:10
  • hmm... that's strange, I've never seen that before Sep 20, 2016 at 23:11
  • I don't know if i did something wrong with the command or anything, because the command always worked... Is there a new way to /tp ArmorStands in 1.10.2?
    – user166129
    Sep 20, 2016 at 23:12
  • 2
    If I had to guess, the armor stand inherited or already had that GUID (global unique identifier AKA that long string of numbers and letters) and now something is wrong with it. Have you tried making a new armor stand an teleporting it? What happens then?
    – Timmy Jim
    Sep 20, 2016 at 23:20

1 Answer 1

1

I think I know how to fix the problem! When you teleport an entity, you have to specify which type of entity you want the teleport and not just the name of it. So, to teleport your armor stand you would do /tp @e[type=ArmorStand,name=Jacob] -459.1 202.0 -840 to teleport it to that location! I hope my command and answer worked for you and if it didn't work please tell me what the result was, Thank You!

1
  • Oh, I didn't know. Soz
    – Mobbuzzter
    Oct 22, 2016 at 5:09

You must log in to answer this question.