13

There seems to be a newish bug in Minecraft where redstone torches burn out sooner than they ought to, and never recover. (I think I heard that this can happen if you use /time set, but this is a single-player world.) I haven't been able to find any info on Minecraft Wiki about it.

How can I prevent this from happening, and how can I repair the problem? (If I remove and replace a torch, then it burns out the very next time it toggles.)

6
  • 2
    AFAIK torches only burn out if they are being switched too fast, can't you modify your circuit to avoid this?
    – fredley
    Commented Aug 25, 2011 at 12:54
  • 2
    I think that the items don't keep their state when they are picked up (especially torches, because they are stackable). So once you pick up a torch and put it back, it's fresh as new. Something must be wrong: a bug in the game, or a problem with your circuit, as fredley says.
    – BlaXpirit
    Commented Aug 25, 2011 at 13:34
  • I'm talking about (after the problem starts happening) a freshly placed torch burning out after a single use.
    – Kevin Reid
    Commented Aug 25, 2011 at 15:11
  • 1
    Just realized that i'm having the same problem =/
    – RCIX
    Commented Aug 27, 2011 at 20:32
  • 1
    I've had this issue on both single and multiplayer. Occasionally it's persisted beyond simply exiting to the menu, so whenever I run into the issue, I quit minecraft completely and restart.
    – zzzzBov
    Commented Aug 31, 2011 at 17:34

2 Answers 2

7

Sorry, I misread, as this time set bug annoyed me a long time on SMP server.

Known bugs on Minecraft Wiki #Redstone Torches

This is a know bug, all you can do is restarting your game. It happens sometimes on random blocks, and it will never work again on that block until you restart. It happens both on single and multiplayer, we hope it will be fixed on 1.8

3
  • +1 This bug has been around for as long as redstone. Notch claimed to have fixed it on several occasions, and things are (were?) definitely better than they used to be, but it's still not fixed. Commented Aug 31, 2011 at 20:59
  • this bug is STILL not fixed and it's so annoying it occurs regulary on the server ive been playing on, usually when the admin sets the time to day/night. After a few minutes it seems to fix itself though, im not sure how.
    – user20167
    Commented Feb 18, 2012 at 23:08
  • Is this still on issue on 1.15?
    – pppery
    Commented Jun 10, 2020 at 17:51
0

Using MCEdit to advance the time forward (one or several days, I forget which) fixed the torches. So it would appear that this was the same problem as the /time set bug.

(I still don't know how it happened...)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .