3

I'm trying to install & update Bethesda Launcher on Windows 7 x32. Every time I run it, it fails, stating

There was an error downloading the required files. Please check install directory permissions and try again.

Actions I'd taken so far:

  • By monitoring it with SysInternals Process Monitor, I see that it doesn't even try to access the Internet.
  • With the same tool I am also able to see that it receives no FAILED result when accessing files.
  • Turned off and removed my AV.
  • Given full access to my user, Administrators group & TrustedInstaller.
  • UPDATE Checked so that no file in it's installation directory is marked as read-only.
  • UPDATE 2 It is of course run as administrator.
  • UPDATE 3 Installation in other directories leads to same results.

I also have Internet access only via proxy server on that PC. It is set as both IE proxy and winhttp system-wide proxy. I suspected that that could be the root of my problem, but as I've already said it doesn't even try to access the Internet.

6
  • Right click the shortcut and select Run as Administrator? Windows UAC sometimes doesn't work like you think it does. It's just really bizarre.
    – Nelson
    Sep 29, 2016 at 2:08
  • @Nelson Already done it, of course. It just was so obvious that I haven't even thought of writing it in my question :) Sep 29, 2016 at 10:59
  • What's the install directory path? Please tell me it's not in Program Files ;)
    – Mazura
    Oct 1, 2016 at 2:45
  • @Mazura Sorry, was kinda busy. Yes, it's in Program Files. I'll try installing it somewhere else, since that's what you imply. Oct 7, 2016 at 15:33
  • @Mazura Nope, didn't work. Tried three different installation location, including %USERPROFILE%, nothing worked. Oct 7, 2016 at 15:44

1 Answer 1

-1

Update:

I uninstalled the launcher, re-downloaded it and reinstalled it to D:\Bethesda.net Launcher. It now runs fine.

My previous install was at D:\program files (x86)\Bethesda.net Launcher. It was also a 2-year-old version of the launcher, but I also tried the new launcher in that same location.

Dunno if it was old launcher files, or running from program files, but it works under the new location with the latest launcher.

Original:

For me at least, it seems to be a permissions issues downloading the file from Bethesda.

I checked in Program Files (x86)\Bethesda.net Launcher\logs\LauncherLog.log, saw errors like below.

I'll keep researching and update this if I get a solution.

2020-12-19T13:54:50Z{Info} Downloading Bethesda.net Launcher

2020-12-19T13:54:50Z{Info} Branch Download task of type 3 added for branch 1 from product 1

2020-12-19T13:54:50Z{Info} Old System - Download Init complete 0.000636343 seconds

2020-12-19T13:54:50Z{Info} Old System - Get Branch Info complete 0.0200335 seconds

2020-12-19T13:54:50Z{Info} Old System - Get Branch Info complete 5.85143e-07 seconds

2020-12-19T13:54:50Z{Warning} [Error Description] User has insufficient permissions

2020-12-19T13:54:50Z{Warning} [Extended Error] 1.31.403.3.1.1032

2020-12-19T13:54:50Z{Warning} [Additional Info] https://buildinfo.cdp.bethesda.net/projects/1/builds/153441/tree/.json

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .