I'm running Flight Simulator X on a pretty decent rig. I can run Witcher 2 at maximum settings with no worries or hiccups and haven't had any problems with other games or applications. I am running Windows 7 32-bit.

Recently, I went back to Flight Simulator X after a hiatus and the QualityWings 757. The only other 'active' add-on I sometimes run with QW757 is REX (Real Environment eXtreme).

I have been getting crashes to desktop usually within the first 30-40 minutes of flight with the event viewer throwing the error:

The program fsx.exe version 10.0.61472.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel. Process ID: 290 Start Time: 01cc636d9e78eda9 Termination Time: 100 Application Path: E:\Games\Flight Simulator X\fsx.exe Report Id: 08a4b755-cf67-11e0-b49b-002683188b74

I've tried a few things:

  1. Uninstalled REX. No dice.
  2. Lowered all the settings (scenery, visuals etc.) to the lowest they'll go, no dice.
  3. Run CPUID to watch temps; all fine - the CPU utilization never goes above 60% anyway.
  4. Applied a bcdedit IncreaseUserVa 3078 switch (the 3078 might be incorrect, I'm going from memory here!). I have since reset this back to 2048 because it was causing problems elsewhere.
  5. Updated drivers and the usual rubbish. No dice.

Then I tried flying just FSX planes. No problems or crashes. I tried other add-ons, PMDG, CLS etc. No problems here either. SO I'm fairly sure it's just the QW757 and I think it has something to-do with OOM. I was a few weeks back getting Flight Simulator has run out of memory and has to close. messages, but they have since disappeared and been replaced with these random freezes and apphangs. I have 4gb of RAM and I'm well aware of the limitations of 32-bit applications (hence the bcdedit switch).

I have had Task Man running alongside the application during flight and FSX pretty much eats everybit of RAM allowed (based on the 50\50 user\kernal split) ...

Any ideas or suggestions as to what may solve the problem? (other than not flying the QW757!) ;)

  • Definitely a problem for QW support which is free for all paid customers (you ARE a paid customer, right?) forum.qwsim.com
    – tkrajcar
    Commented Aug 28, 2011 at 6:30
  • Absolutely, turns out I didn't have Service Pack 2 installed. After plopping that on, all seems well - no crashes. I've even reinstalled REX for extra fluffy clouds! :)
    – dooburt
    Commented Aug 30, 2011 at 10:23

1 Answer 1


Turns out I was missing Service Pack 2 and the Service Pack 2 Hotfix which I got from QW. Since installation, I've re-installed REX and my 752 has been bouncing through the extra fluffy clouds with no problem. I had visited the QW site, but assumed that the installation of v1.2 that I bought would have contained the SPs, so didn't think to look there.

So, kids, always check the official site first!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .