15

I know that several versions ago (pre-1.0) that there was a stability bug that would cause parts to start vibrating heavily on load, causing things to pull apart, explode, or some other nasty result. I've had a Minmus base for months now (that's real-world months) and haven't added anything to it in several days. I am running the KAS/KES mods, but again haven't done anything to this base for days, but unfortunately now, every time I switch to that base, or anything close to it, the ground starts violently shaking and all my stuff blows up and gets launched into the air. I know that clipping can be a part of this issue, but again that bug was supposed to have been fixed a while back. I can't find much info about this issue post-1.0, but I was curious if anyone had any ideas as to what I might be able to do to prevent this.

Here's a video of what is happening, as described above.

Update: I know that while in space (not in any atmosphere) you can stop rotation or otherwise shaky movement of spacecraft by quickly warping to the next warp level then back to 1x time. This culls the movement. I tried this on Minmus as soon as the base loaded, and it did stop the "quake". The problem is that as soon as I warped back to 1x time, it started all over again and the base still was destroyed. Not sure if that tidbit of info is useful to anyone.

Update 2: With the new 1.2 patch, I was hoping some of the stability fixes would resolve this issue, but either that's not the case, or the older version save game is not fixable. For now it will stay put on Minmus while I do other things, but I'm still looking for a resolution.

Update 3: In desperation, I loaded the base again, and it started to quake again after a few seconds. I went into warp x2 mode, and it stopped. Stayed there for several seconds, then went back to 1x, quake started again... I did this cycle about 4 or 5 times, and I noticed that the quake started more and more slowly (and with less intensity).. so I got the feeling that the few seconds before and after the time warp was allowing things to stabilize as the parts stopped moving. Another 10 or so cycles of this and I'm now able to sit in 1x (no warp) and have the base not explode. I was even able to turn off and retract my ore driller, and everything is still sitting here just fine.

So maybe that is the answer -- careful and precise timing of warp/unwarp to slowly calm the physics down. I'll wait a few in-game hours and see if it still works, then post it as an answer officially.

  • I haven't played KSP in a while, but have you recently updated/added any new mods or has the game updated? I know updates in the past would occasionally break save games when parts are updated. Sadly it is not fixable if that happens. – Banh Mi Dac Biet Oct 6 '16 at 13:27
  • I keep the mods updated, but it's been a while since updating, and I've actively used the base several times since then... thanks though! – Tim S. Oct 6 '16 at 13:31
  • 1
    Interesting. I was going to recommend turning SAS off, but in the video, it's already off... I'm stumped. – Coomie Oct 12 '16 at 3:38
  • 1
    It's the number of KAS pipes connecting the modules. They like to introduce phantom forces - but it's hard to give them up :) Another method that helps somewhat is to replace them in winches left in "release" mode. – SF. Oct 13 '16 at 23:06
  • 1
    Some thoughts... There's a mod called World Stabiliser which starts with the physics disabled and ramps up over a few seconds after scene changes/warping. Gives everything a chance to settle. Might help you/others. Also... Re: keeping mods up to date, conside rusing CKAN. The vast majority of mods are listed and you can even save mod configurations and reload later. – Basic Dec 18 '18 at 18:21
2

Have you tried Kerbal Joint Reinforcement. That usually fixes shaking and wobbling glitches. Kerbal Joint Reinforcement

2

If you're using KAS and KIS, you can keep the base from jumping (although not breaking apart at seams if the 'quake' is serious by application of the Launch Clamps AKA Launch Stability Enhancers.

enter image description here

It's not easy - the largest KIS container can only fit one launch clamp, and they are extremely ungrateful once 'out in the open' - soon after 'deployment' (switching craft/kerbal' or such) they 'solidify' and become absolutely 100% immovable - there is no force in the world that can move a 'solidified' launch clamp, and while the joint to whatever it attaches to is subject to normal physics rules, it's very, very sturdy.

Note: attach the clamps into 'one smooth motion' - straight from the inventory to the attach location. Don't drop them along the way, don't attach them to other parts, and above all do NOT try to change the attachment point of an already solidified clamp, or rotate it. The clamp won't move. But the attachment point WILL change. So your base will 'move' to adapt. Usually in a rather explosive manner.

Extra benefit: the clamps generate 25% more power than the RTG at maybe 5% the price.

  • Oh interesting! I had no idea you could put launch clamps in an inventory container -- I never thought to try. If I can ever get things to not explode on load, I'll give it a shot. Thanks for the tip! – Tim S. Oct 13 '16 at 13:27
  • MKS parts have a "ground tether" that is supposed to work like sort of like this, but it can be toggled. It mostly worked for me. – Dan Ross Feb 27 '17 at 6:55
  • 1
    I tried this, and ended up with a base dangling dozens of meters above the surface from a launch clamp that suddenly decided to become very tall… – Atario Jan 15 '18 at 22:11
1

Sorry to be (VERY) late to the party, but I'd just like to give another solution for those still experiencing this issue with their bases. I'm honestly surprised nobody has proposed this one yet.

This solution uses KAS. If you place something on the floor, H + LClick will bolt it down, and make it unmovable. This is useful for something like Pathfinder, where you assemble bases with KAS.

If you've already landed something and just want it bolted down, you can attach CC-R2 Connector Ports to the base. Then bolt down (H + LClick) one Ground Pylon or CB1 Ground Base per port. Add a connector port to the Ground Bases or Pylons. Link the connectors together via their RClick menus and that will bolt the base down.

It should look just like Bill Kerman's demonstration here:

All bolted down and secure!

0

I have this problem as well.

I found that if I retract all solar panels and shut down my mining drills and converter whenever I dock a rover or another expansion that my base remains stable. Also lock the brake on your rovers after you connect to base.

0

So after several different attempts, I've finally come to the conclusion that only warping is the only way to avoid this. Even with clamps and other reinforcement mods, everything still starts shaking violently. Even though some scenarios the quaking didn't send things hurdling into space, there was still movement and some explosions. Warping once just after the scene loads was enough to permanently (for that session at least) stabilize the base.

I'd like to see some updates to the game to increase stability (like resetting the collision of landing gear with a planet's surface to zero on scene load) or anything that may actually fix this. It makes me not want to invest any more time into that base for fear that it will just end up getting to big and unstable again, exploding even before I can warp.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.