3

I am playing Minecraft 1.10 on a normal difficulty (unmodded) and lately I've experienced that all my monster spawners seem to be broken. They don't show the actual monster rotating inside of the cage, but something that looks like a pig, and nothing is spawned from them. This happens for spawners in dungeons as well as blaze spawners in nether fortresses. It doesn't only happen on newly discovered ones but also ones I already found and which worked properly in the past.

Spawner 1 Spawner2

To be honest I can't pin down exactly when this happened, as I make bigger pauses in playing and haven't ventured that much into dungeons or the nether in general lately. What I can say is that it definitely worked back in 1.8 and maybe in 1.9.

Some time ago I switched back from my up-to-date (1.9 or 1.10) pure profile to an OptiFine one from 1.8.8 and used a custom texture pack. But this messed up all my armor stands (which lost all their armor) and my grass paths. This may also have messed up the spawners. However, I didn't venture into the nether when I tried that and I also successfully played this profile back during 1.8 times when those spawners still worked fine.

So, does anyone know why this happens and more importantly is there an easy way to fix it (without just going around and manually /give-replacing every spawner like I did with my lost armor)?

2

A pig in a mob spawner identifies it as a "player generated" spawner - i.e. one that was placed by a player in creative/using cheats. When a player places it down, it will show a pig, and not spawn any mobs[citation needed] until a mob egg is placed on it (like a skeleton/spider/zombie etc.).

Visit this answer for more information.

As for why this occurred, it could be one of many reasons:

  1. If you're playing on a server, either a mod did this, or a server glitch occurred.
  2. If you're playing on a LAN, another player may just be trolling you.
  3. If you're not playing on a LAN, it could simply be a world glitch. It may have occurred during a game patch/version update.

As for fixing it, the only real solution is to either talk to your Server Admin (if applicable); try and find an old world save and restore that; or simply just start a new world.

  • 1
    I play it in private. I only ever opened it in a LAN for a few /give "cheats" (with noone else joining, though). Sadly none of your solutions for fixing it are really applicable. But thanks for the answer anyway. – Ulukai Oct 12 '16 at 10:35
  • I guess my best choice is using something like MCEdit and fixing it from there. While the normal monster spawners aren't that big a deal, it would be unfortunate to lose the blazes. – Ulukai Oct 12 '16 at 10:40
  • In that case, you could use the same method to replace the spawners, and use eggs to set the mob type for the spawners, but that will be a bit of an effort, and I'm not entirely sure how "permanent" that might be – Ben Oct 12 '16 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.