7

How can I disable the map introduction screen (MOTD) shown when joining a new server or changing maps?

I've understood that the game ceases using intro when the player has visited a map a specified amount of times (the value is likely high, such as 50).

MOTD screen

(can require up to three mouse clicks to skip, autoplays video & audio)

  • 1
    I found file viewed.res in ~\Team Fortress 2\tf\media, I set all values to 50. If that works I'll post an answer. Source: gamefaqs.com/boards/437678-team-fortress-2/61603528 – user598527 Nov 3 '16 at 10:00
  • Doesn't work, but the file doesn't include all maps by default, only those played by the current user. Reinstalling or verifying game cache resets the log it seems. – user598527 Nov 5 '16 at 17:21
  • Which screen exactly are you talking about? The screen in the screenshot is the MOTD and it shows every map change. It's set by the server owner and is sent by the server on every map change. – Powerlord Dec 30 '16 at 13:44
  • @Powerlord: In that case, about MOTD. – user598527 Dec 30 '16 at 13:58
2

The command cl_disablehtmlmotd 0 disables MOTD. Goes into the console, but will only work for unofficial servers and not Valve ones.

| improve this answer | |
  • can also be used in autoexec.cfg – user598527 Apr 5 '17 at 16:13
  • 1
    Are you sure it isn't cl_disablehtmlmotd 1? – user598527 May 26 '17 at 23:20
2

You can't.

Source Engine has two types of MOTD: plain text and HTML. If client will choose to disable HTML MOTD, it falls back to plain text.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.