I have a problem with Football Manager 2017. The text looks blurry when I'm starting it on my laptop (Windows 10). The resolution on my laptop is 1360x768 (In game it is 1366x768). I have 2 video cards

  • Intel(R) HD Graphics 4000
  • Nvidia GeForce 610m 2GB

I don't know that much about video cards but I read that the normal approach is to use Nvidia for your games and the intel driver for normal usage. Correct me if I'm wrong.

When I checked my Football Manager it was using the intel driver (I got 1/5 stars for the 3D strength of my laptop):

enter image description here

So I tried to force my game to use the nvidia driver (using the Nvidia configuration screen). It's in Dutch but you'll understand it.

enter image description here

But no success. The text of the game remains blurry + the driver did not chance. Can someone tell me what I'm doing wrong? I checked with a friend and his Football Manager game was using his Nvidia card by default (other intel + nvidia card). I updated my drivers.

  • Just for clarification, you only have 1 "video card" (the 610m - and its not really a card in the case of a laptop but people still call it that). The Intel graphics are integrated with your Intel processor. What you really have are two GPUs.
    – Timmy Jim
    Nov 9, 2016 at 22:19
  • Did you make sure to reboot/shut the game down first? It seems like you've followed the correct steps based on the developer's own page: community.sigames.com/faq/football-manager-2017/84_how-to/89_pc/…
    – NBN-Alex
    Nov 9, 2016 at 22:19

1 Answer 1


Give what LeonMordecai said in this post a shot:

  1. Right click on the desktop and open nvidia control panel (or you can go find the nvidia icon on the taskbar)
  2. Navigate to "manage 3D settings" drop down under 3D settings.
  3. Under the global settings tab, underneath preferred graphics processor, change it from auto detect to high performance graphics processor.

This will make is so your laptop will always use the 610m GPU (instead of just for the specific .exe). If that doesn't work, try disabling your integrated graphics completely (you'd rather be using the 610m over the integrated anyway).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .