2

I made a dedicated server for gmod, (You can actually join it to test, its "FinnWorld")

Others can connect to it, its forwarded, np with the firewall, the ip is correct, WHAT THE FUCK IS WRONG

error msg by gmod: Connection failed after 6 retries.

my start.bat: @echo off

title srdcs.exe Watch_Doges
:srdcs
start /wait srcds.exe -console +hostname "FinnWorld[WIRE][FASTDL][PAC3][PVP & BUILD]" -game garrysmod +map gm_bigcity +maxplayers 16 -authkey (MY AUTHKEY, NO I WONT LET YOU KNOW IT!) +host_workshop_collection 798333332 +login anonymous +ip 192.168.0.100
goto srdcs
2

Ok, It turns out that when I was running gmod and the server on the same computer, the server was sending out stuff at port 27015 and gmod tried to send out signals on 27015. changed port to 27016 and +clientport 27006 if it still doesnt work. I'll leave this out here if it intrests somebody

2

Using correct srcds command line parameters

Source dedicated server comand-line options may be misleading.

You should specify bind address and listening port with -ip and '-port' (NOT +ip/+port. Options beginning with - is a command line parameter whereas + indicates ConVar

All available Source Dedicated Server command-line parameters are listed here (6.1)

+ip 192.168.0.100 is wrong. Correct command line parameters is:

-ip 0.0.0.0 -port 27015

Always use -ip 0.0.0.0, DON'T use any other address

Connecting to your server

Source games will not connect to your server if you don't type correct LAN IP address, so, there is two ways:

  1. (easy) Open your game, click "Find servers > Legacy serverbrowser > LAN tab"
  2. (easy) Right click on steam icon, "Servers" > "LAN".
  3. Find out your LAN ip address (via command-line: ipconfig or ipconfig /all, "IPv4-address", one of them will be your desired address) and connect to it via console connect 192.168.0.2:27015. Make sure server is actually listening on that port.

Sometimes (re)starting a server while game is running may result in server using different port.

You can't connect to source server via connect 127.0.0.1:port regardless of server's bind address, port or other settings!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.