I've recently gotten a new laptop, and am attempting to play Spiral Knights on it, however the game simply will not load. Every time I attempt to start it, I get a "This game is currently unavailable, please try again at another time" error. I've tried verifying the integrity of the game cache, deleting the local content and reinstalling, rebooting my computer... nothing works. Since this has persisted for a few days, I doubt it's on steam's end, is there any fix for this?

  • is your firewall open for whatever port spiral knights needs? Also, it helps if you post your OS (I'm assuming windows 7?) Try running the game as administrator.
    – l I
    Aug 31 '11 at 1:53
  • As yx_ said, try running the game as administrator. It looks like the game is having some permission problems.
    – mordi2k
    Aug 31 '11 at 1:57
  • I'm using a mac OS X v10.7 and an admin account. I don't think permissions are the problem here. Aug 31 '11 at 2:17
  • 1
    Have you tried using the solution posted at the steam forums? -> forums.steampowered.com/forums/…
    – mordi2k
    Aug 31 '11 at 2:23
  • I totally missed that topic, that guy's a genius! Problem solved. Post it as an answer and I'll accept it ASAP. Aug 31 '11 at 2:53

The OS X version of the game has some issues with permission handling. The solution is to add the permission via the terminal:

  1. Open "Terminal.app"
  2. Type: cd /Users/<username>/Library/Application\ Support/Steam/SteamApps/common/spiral knights
  3. Hit Enter
  4. Type: chmod +x run.sh
  5. Hit Enter

Then the game should run normally from steam.



The OS X distribution doesn't give the launch script execute permissions (source).

To fix, in Terminal:

cd ~/Library/Application\ Support/Steam/SteamApps/common/spiral knights
chmod +x run.sh

(If that path doesn't work, try it without the tilde or with "Users/[your username]" instead)

(You must be running as superuser to do this. Use sudo chmod +x run.sh if you're not an admin.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.