4

Before you jump to conclusions, I've tried to solve this before asking.

I cannot seem to get Minecraft to go above 5% of the allocated memory. Here's what I've done: set the max fps to like 130, updated Java, allocated like 8 gigs of RAM using the -xmx thing, and installed optifine. There is no reason my computer should lag on Minecraft. I have a GTX 980M and 16gb of RAM.

Is there some way that I can tell my computer to use more than like 400MB of RAM on Minecraft? Thanks.

  • 4
    Just because it's allocated doesn't mean it's going to use it all the sudden. What type of issues are you experiecing? – NBN-Alex Nov 22 '16 at 17:46
  • Maybe you aren't using more than 5% of allocated memory? – rivermont - Will B. Nov 22 '16 at 18:03
  • @NBN-Alex just low FPS when I wouldn't expect it, as this computer runs games such as battlefront and battlefield decently. Normally my computer makes a lot of noise from the fans when I game, but not when I play minecraft. – Kemosabe Nov 22 '16 at 20:42
  • Does your laptop have integrated graphics as well? Make sure minecraft isn't using that instead of your 980m. Are you running in power saving mode? Make sure your CPU isn't being limited by a power option. – Timmy Jim Nov 22 '16 at 23:08
  • I've run into the integrated graphics problem before. How does one configure that? (pretty sure that's the fix, as in game it shows my intel card and not my GPU..) – Kemosabe Nov 22 '16 at 23:30
3

Check if your integrated graphics are being used for Minecraft.

  1. Right click on the desktop and open nvidia control panel (or you can go find the nvidia icon on the taskbar)

  2. Navigate to "manage 3D settings" drop down under 3D settings.

  3. Under the global settings tab, underneath preferred graphics processor, change it from auto detect to high performance graphics processor.

This will make your default graphics processor your GTX 980m.


For checking your power options:

  1. Search for "Power Options" in the search bar or search feature (Windows 10/8). Otherwise, navigate to it through the control panel.

  2. Click Change plan settings next to the power plan you wish to use.

  3. Click Change advanced power settings.

  4. Choose your desired settings then click Apply.

  5. Click OK to save your changes.

I recommend using balanced, as this will keep the CPU from running full speed when it doesn't need to (like when the computer is idling), but will speed up the CPU when it's under load, such as playing a game. I belive there is one set of power rules for when the laptop is plugged in and when it is running on the battery, so be sure to check both. Note thay when you are running on battery power, using the high performance option will drastically lower your battery charge time.

Hopefully this solves your lag problems. When hardware is being limited due to being on a low power mode, the symptoms you describe can occur. A GTX 980m should have no problem running Minecraft.

  • You can still change the settings for only one program. Java is not in a list by default, you need to search for java executable and add it. That missing in such a list makes it to use default - integrated graphics :) – Antoine Hejlík Nov 23 '16 at 16:23
  • Yes, you could do it per application. I recommend using the 980m over integrated though since it's much more powerful. The only downside is its going to use more battery power. – Timmy Jim Nov 23 '16 at 17:04
4

No.

The allocated memory will be used as it is needed. The allocation simply determines the maximum. However, if Minecraft does not need that much memory, it'll just not use that much.

If you load up a typical Minecraft game, it'll only load up a single chunk, and as you move away from the loaded chunk, it'll unload unused areas.

If you are having an actual problem, you should ask about the problem itself instead of thinking the problem is due to memory allocation.

  • Thanks, what then do you think would be appropriate to ask, something along the lines of "minecraft lag, no clue why?" – Kemosabe Nov 22 '16 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.