1

I have bumped into few glitches while doing the Liberation of Skyrim quest-line and these glitches wouldn't allow me to advance this quest-line as it won't let me report back to Ulfric.

After I completed the following quest from Ulfric:

Capture Whiterun from Jarl Balgruuf

I noticed my first glitch was that the combat music wouldn't stop. I tried fast traveling, sleeping, entering & exiting combat, getting placed in jail, restarting the game, and killing everyone around me but the combat music wouldn't stop. I decided to just move on with the game as I thought the glitch would just eventually stop. I did see this post, however these commands obviously do not work on Xbox.

I proceeded to:

capture additional forts and complete the The Battle for Fort Hraggstad in the Liberation of Skyrim quest-line.

My next task in the quest-line was to report back to Ulfric. I talked with him and he rewarded me for capturing that last fort before advancing the Liberation of Skyrim Quest:

Capture Solitude

He gave me some coin and offered me the title of Thane of Eastmarch as long as I purchased a house and helped 5 citizens in Windhelm. I ended up completing that quest-line and he granted me that title of Thane of Eastmarch.

This is where my next glitch came into play - The next task for the Liberation of Skyrim quest-line was to report back to Ulfric, however, doing so wouldn't advance the quest.

Therefore, I couldn't start the Battle for Solitude quest

I tried talking to Ulfric again, reloading to a previous (not far away) save point, attacking him, downing him, killing his guards, obtaining a bounty, spending the night in jail, fast traveling, waiting a day, talking to Galmar again (as he originally told me to back to Ulfric), going to Solitude (he wasn't there) but nothing would work.

How can I fix these glitches ? How can I advance the Liberation of Skyrim quest-line? What caused this to happen?

1

TL;DR

Reload to a previous save prior to your battle for Whiterun and don't receive a bounty while in the battle for Whiterun

So after a few days of testing several save points and googling the fix, I was able to resolve this glitch by sadly reloading back to a previous save point (losing about 10-15 hours of gameplay as I did other quests while also do the Liberation of Skyrim quest-line). As this took me several hours to figure out, I figured I would post this as an answer-your-own question to help out anyone else stuck in the similar situation(save them time / headaches).

I was able to (accidentally) duplicate both glitches by reloading just prior to this point:

the Battle for Whiterun

I duplicated these glitches by accidentally getting a bounty placed on me while inside the city we were attacking as I did a shout on a few enemies and there must have been splash damage. I saw a bounty was placed on me for Whiterun and Eastmarch (it wouldn't let me pay this bounty in either city(even after forcing incarceration)). I immediately sheathed my sword and dagger as Galmar started attacking me when that bounty was placed on me. Galmar stopped attacking me and we proceeded to the Jarl. After that battle was over, the music didn't stop again and eventually I couldn't advance the quest-line just like before.

This sparked my memory of the first time around during attack on Whiterun.

I remember receiving a bounty on me from both cities as I was pillaging from locked cases from the street vendors during that battle.

I reloaded again prior to that battle and completed that battle without obtaining a bounty. This time around, the combat music promptly ended once I completed that quest and I could continue with the Liberation of Skyrim quest-line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.