1

I am currently running a FTB Infinity Evolved server with the FTB Utilities mod making automatic backups for me on a two-hourly basis.

I want to change the path of where the backup is outputted to. In the config file (\local\ftbu\config.json), the location defaults to "folder": "./backups/". I want to change this location to another location on the computer. Specifically, E:\Lexus\Documents\Dropbox\Backups\MC\FTB Infinity Evolved

I have tried using /forward slashes but when it creates the next backup, it removes the forward slashes of the path and just creates a folder on the root of the drive (E:\LexusDocumentsDropboxBackupsMCFTB Infinity Evolved). I have changed the /forward slashes to \back slashes as this is how the path is displayed on the running server's command console; the same thing happens.

Can someone advise me of the format that path names need to be written in a .json file please?

Thanks

Lexus

1

Half a year ago I had it working just fine (on Windows 7) by setting it to:

    "folder": "F:/FTBbckps/",

I'm not sure what the problem on your side might be. Make sure you have it in double quotes and add the trailing slash just in case?

If that does not work, one other idea is to try escaping the forward slashes. JSON uses backslash as an escape character, as far as I know, but it might not be a JSON problem. So probably try both "E:\/Lexus\/Documents\/..\/" and "E://Lexus//Documents//..//"

| improve this answer | |
  • Thanks for the suggestion Gedas. I will give this a try today to see if I can get it to work as expected :) – Gaming Lexus Dec 2 '16 at 12:11
  • I now have it backing up as it should. I'm not quite sure what happened :/ Thanks for the suggestion. – Gaming Lexus Dec 3 '16 at 23:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.