I'm using Blizzard Authenticator and Starcraft II login screen prompts me each time to enter the code. Everything would appear to be fine, unfortunately it isn't:

Blizzard recently announced that they have updated the authentication system to intelligently track login locations and, if one is consistently connecting from the same place, may not be asked for an authenticator code.

That new feature worked flawlessly for a few days, but suddenly it stopped. Nothing changed in my machine, and I'm using the very same computer to play. I'm being prompted again to enter the code every time, even after watching a legacy replay.

I want to find out what's causing the problem. I would really appreciate any advice you may have.

UPDATE: I have a static IP (Sorry I didn't mention that sooner)


It's either because your IP address changed (which is likely if you haven't specifically purchased a static IP plan from your internet service provider) or it's been a week since you last authenticated:

From the the Blizzard WoW Forums:

your account no less secure than it was before, the only change is that you will only be prompted once a week to enter unless you change IP address, from where you'll need to enter your authenticator code.

Unfortunately, the Blizzard FAQ is worded in a way that sounds like he new functionality won't always trigger

The Authenticator system will now intelligently track your login locations, and if you are logging in consistently from the same location, you may not be asked for an authenticator code. This change was made to make the authenticator process less intrusive when we are sure the person logging in to your account is you.

Also, according to the EU FAQs, this isn't active for SC2 accounts at this time:

Please note that this feature is not yet live for StarCraft II accounts.

| improve this answer | |
  • My IP does not change and I'm still being prompted each time I log in. The problem seems to be much more complex, that's why I've posted my question. – user12002 Sep 2 '11 at 19:24
  • @mission This sounds like a technical support issue, then. I'd suggest contacting Blizzard's support staff if the system is not operating as it should be. – Shaun Sep 2 '11 at 21:30
  • I already did that. It seems that they know nothing about the problem and I received a standard response to post on the forums. IMO they are never really helpful when it comes to uncommon problems. – user12002 Sep 2 '11 at 21:52
  • @misson Yeah, unless you can fight past their initial tiers of support, they're not always helpful. I dug into their support FAQs but they're not definitive, either. They actually hint that the new functionality may not always trigger. Also, if you're in Europe, that might explain it. The Europe version of the FAQ says it's not working for SC2 in Europe. – Shaun Sep 2 '11 at 22:56
  • That explains everything. Basically the new functionality worked with European SC2 initially, but for some reason they withdrew from it (at least for the time being). – user12002 Sep 3 '11 at 0:34

I don't know how Blizzard is logging locations but if they are using ip addresses then that could explain it. Because if you have a broadband modem, normally your ip address never changes until the modem loses connection to the isp. Now the isp can switch your ip address if they need to and Blizzard would be thinking it is a new connection therefore requiring you use your authenticator again.

| improve this answer | |
  • Of course that would be the reason if I had dynamic IP. The problem is that my IP does not change and still I have to type the code every time (like few times in a row during one hour). The new feature for some reason simply does not work at all on my machine and I want to find out why. – user12002 Sep 2 '11 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy