2

So I'd been playing DkS3 for an embarrassing number of hours, working through NG+ and decided to grab the new Ashes of Ariandel once I made it to the cathedral.

I was able to play around on the new snowy map for while before realizing everything (not excluding the trees) is more than capable of devouring me. So I went back to finish my NG+ playthrough.

Well at some point (I believe my PS+ account may have expired (and I don't have it automatically re-subscribe)). Before re-subscribing, I try launching my DkS3 account and get the following image:

enter image description here

Notice how the "Ashes of Ariandel" indicator is now missing from the version information at the top left of the title screen? So I re-activated my PS+ account, re-load DkS3, but still no dice.

In short -- I have an active PS+ account, I have the DLC and season pass purchased and installed, yet I can't seem to get beyond this error. What gives?

2

Not exactly an answer, but these are the steps I took to correct the problem:

  1. Close Dark Souls 3 Application completely

  2. From the XMB (or whatever its called), go up to "Notifications", then highlight or "New"/"Notifications"/"Downloads" or whichever lists the DLC and allows you to "Download" or "Install" upon selecting it

  3. Once the installation is complete, start DkS3 (you will still not see the DLC indicator up in the top-left info pane) and create some new character that you can promptly delete once this whole debacle is resolved.

  4. Exit the current game, and then close the DkS3 application.

  5. Now start DkS3 and you should now see the DLC is properly registered and displayed in the top left of the main menu's information corner.


NOTE I want to point out that these steps could be entirely unnecessary and the fact my DLC is now registered is simple incidental with PS+ system update cycles (the steps I took above took at least an hour to complete)

0

I found the solution here: https://community.us.playstation.com/t5/Games-Services/PS4-Pro-thinks-I-have-Dark-Souls-3-DLC-installed-when-I/m-p/46123742

Basically, you have to start the console in safe mode and rebuild database. Then you will be able to download the DLC.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.