So I live in mainland China, under the surveillance of the infamous Great Firewall. However, for my surprise, I am perfectly able to browse in my 3DS' (as long as I don't access a "forbidden" website) and (not so perfectly) access eShop and download games etc. However, it seems to me that some in-game (and maybe others) online features are being blocked by it.

In my case I have a problem with in-game online operations in Pokemon Sun. Every time I try to trade or battle online I get an error, usually error 001-0502 but eventually also error 001-0803. This seem to suggest I might be having a problem when trying to connect to the server. I tried and look for nearly everything that could be googled but nothing really seems to work. So I cannot help but to wonder if this error isn't being caused by the Great Firewall, which is blocking my connection to Nintendo's servers?

Putting the question in a more general form:

How is 3DS' online gaming experience affected by China's Great Firewall?


1 Answer 1


Error code 001-0502 is a network problem, as stated in the Nintendo website. To solve it, change your 3DS DNS to or or try using a VPN. Also, it appears that you may need China Unicom broadband as a prerequisite (i.e. if you're using the Great Wall Broadband, you're pretty much on your own).

Adding on, apparently the majority of people who get this error are using their school's internet - they have the same conditions as you - able to access the ESHOP etc but not the game's internet. Another recommendation (if the previous paragraph didn't work) is to use the internet from your phone's hotspot.


Most of the error codes starting from 001 (including 001-0803) means that you're (likely) blocked by the firewall and you'll need a VPN to bypass it. (Source)


Answering your general question, most of my Chinese friends use a VPN to do anything on the internet, which includes playing games and accessing Facebook. Likewise goes for 3DS gamers - they need a VPN.

  • This is so informative, thanks dude! For the record, I've managed to solve the problem by bypassing the GFW using the virtual WiFi hotspot support in Windows (I used this tutorial of Astrill VPN). As a result, I think it is safe to assume that the problem was caused by the GFW. Commented Dec 14, 2016 at 9:12
  • @StudentType You're welcomed! Glad it worked out :)
    – Yuu
    Commented Dec 14, 2016 at 9:24
  • @StudentType Don't think that's necessarily the GFW which caused the issue in this case. Might just be the settings of the particular network you're in, e.g. campus network. Even western companies will have a lot of restrictions on their internal network and you might not be able to use software e.g. Steam on it.
    – xji
    Commented Dec 18, 2016 at 16:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .