6

Basically, my problem is I cannot play Pokemon Go while on mobile data. I can't play because whenever I open the app while I'm on mobile data, it turns the mobile data off. I can however play while on WIFI connection, but it sucks that I can't walk around anymore and play the game.

I have tried all fix that I can search of,

  1. Cleared the cache, uninstall and reinstall.
  2. Made sure that Pokemon Go, Google Services and Google Play are enabled on mobile data.
  3. Created a new account using the trainer club.

This has given me no improvement at all. I still can't play on mobile data.

I have posted a screen capture video of my phone while it is having the problem.

As you can see in the video that I can browse the internet, it's just that it turns off whenever I open the Pokemon Go app.

I have a Sony Xperia Z3 by the way so I don't think this is a phone compatibility issue since I was still able to play the game on mobile data since last October. Then on one fateful day, it won't let me play anymore.

Please anyone that could help me out. Thank you so much.

  • 1
    Have you checked if your phone has any options that turn off mobile data if you're requesting too much data? Like some sort of data saving option? – Slippo Jan 24 '17 at 0:44
  • I don't mean this to sound condescending, but, did you try a hard reboot (power cycle)? – pjmorse Apr 21 '17 at 15:36
1

Turn on flight mode, wait about 5 seconds, then Turn off flight mode, wait a couple more seconds.

This has worked for me several times in a row. Another fix is to start up the game while on Wifi, and then disconnect the Wifi in game. Although if you do this, the same disconnect will happen if you exit the game. So you have to continue playing.

Please also check this forum for more information.

  • atleast either accept the answer or something man ?????? – arslan babur Feb 17 '17 at 11:18
  • 1
    or just comment it didn't work – arslan babur Feb 17 '17 at 11:19
0

Maybe check if you have allowed Pokemon Go to use Mobile Data in Settings. It might be that you haven't allowed it to use Mobile Data.

  • he specifically said that he has it enabled. – Hulkerman Aug 22 '17 at 5:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.