I have an update for CS:GO and Dota 2, but when trying to update the game it pauses abruptly, normally near the end, with the pause message "CORRUPT UPDATE FILES". Here is an example of what they look like:

An image of CS:GO and Dota 2 in my steam queue being affected by this problem.

How can I fix this?

Currently I have tried the following ways to resolve this, none of them have worked:

    1. Navigate to the steam library that CS:GO is located in.
    2. Enter the downloading folder, steamapps/downloading/.
    3. Delete all files and folders with 730. This is as 730 is CS:GO's app ID.
    4. Try updating CS:GO.
  1. Verify integrity of game cache.

  2. Clear download cache.
  3. Update the game from another account, as a forum post suggested this.
  4. Reboot PC.
  5. Update game from a fresh OS.
  6. Uninstall the game, and then re-install.
  • Personally, at this point, I'd try to uninstall CS:GO and DOTA2...And then reinstall it from scratch
    – Karlyr
    Commented Dec 15, 2016 at 1:15
  • Is it pointing to the correct drive where the installation is? Commented Dec 15, 2016 at 5:37
  • Sounds a lot like you might have something interfering with HTTP downloads, possibly some malware or proxy modifying contents, injecting ads or similar.
    – Mario
    Commented Dec 15, 2016 at 8:26
  • @Peilonrayz There is no reason to go as far as a brand new OS install just yet. Try uninstalling and reinstalling the games first before resorting to such an extreme measure. Commented Dec 15, 2016 at 14:42
  • Came here to say thanks for the steps. I was having a similar problem, but step 1 resolved it. Paying it forward!
    – Val H
    Commented Sep 13, 2021 at 1:02

1 Answer 1


There seems to be a problem with installing a game on a ntfs-partition with Steam on Linux. Try to mount your ntfs partition with these options in your /etc/fstab file:


Solution from here: https://github.com/ValveSoftware/steam-for-linux/issues/4800

  • How do you know this is linux?
    – Timmy Jim
    Commented Feb 25, 2017 at 21:23
  • @TimmyJim I had the same problem on linux only (also tested on windows) and found no other source of information except the stated link. Granted, it was still a lucky guess. Commented Feb 28, 2017 at 16:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .