1

Hello I have a few games on Steam that I had downloaded, i downloaded space engineers yesterday, today I log on and need to update it. I try to update it but it get's to 98.0mb/2GB and it stops. If i press pause or try move a different game to the top of the queue it just resets back to 0mb/2GB and then gets stuck again. Why does this happen. I live in Ireland and when I tried to set it to download from the UK or Sweden in the settings that would not work either. Does anyone know how to fix this or what do I do? I did uninstall steam and reinstall steam and it still dosn't work. Heres an image.

Image of download screen.

  • How long have you left it for, it's possible that the game is doing something with the files mid download before it resumes – Alfie Goodacre Dec 16 '16 at 17:07
  • its been 5 hours, it does it for every game I have. CSGO, SPace engineers, terraria, tf2 etc. – Jelly Dec 16 '16 at 17:10
  • In that case, have you tried installing something new? It could also be your hard drive space – Alfie Goodacre Dec 16 '16 at 17:10
  • i have 280GB/800GB free – Jelly Dec 16 '16 at 17:11
  • 1
    I know you've already had this suggest - and it's a bit of a pain - but you might try a few other locations. I had this issue a few weeks back and tried about 6 locations, in the US, where I live. None of them were working, for anything. Finally I gave up and tried St. Petersburg, Russia. Downloads worked fine from there. (I wouldn't keep it on a long-range server, but temporarily.....if it works.) (Note: x_Vex_x's comment on the above mentioned steam thread, was the reason that I tried Russia, though I haven't seen this thread before.) – Khale_Kitha Dec 16 '16 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.