So, I was playing Mass Effect 2 and as I was walking the screen just kind of froze, I could still hear sound playing fine so I knew the console didn't freeze. After about 2 minutes of waiting a screen came up that said the disk is scratched or dirty. Well, the problem is I was playing the Kasumi DLC so it was being read from the HDD.

I restarted the console after that and it started to do things that it shouldn't be doing. It will either say there is a profile available or not, depending on the restart. Or it will sign into my profile on XBL and even notify me of whose online. Or it will tell me whose online while saying that I'm signed out.

I've tried doing a profile recovery, but I keep getting an error that XBL sign up is unavailable.

What can I do to fix this? Is there a way to perform chkdsk on the HDD? I'm 99% sure it's just a corrupt sector that needs to be fixed.

Anyway, I hope you guys might have a solution. I don't feel like spending money on this console. I don't know what gen it is, but it's the white chassis with 4GB built in.

  • You could try to connect the HDD to your computer, and run the chkdsk from there.
    – mordi2k
    Commented Sep 4, 2011 at 4:19
  • I just tried that. It wouldn't recognize the HDD. I tried mounting it and Windows asked if it should be MBR or GPT (I think) and I tried both. Neither allowed me to assign a drive letter for it to work with and now I can't get the Xbox to recognize it either. I think I screwed up the partition headers...
    – Gup3rSuR4c
    Commented Sep 4, 2011 at 5:38
  • Point of clarification: Is Mass Effect 2 installed on the hard drive or being run off the disc drive? I know the DLC is on the HDD, but where is the main game being accessed from (even though you are using DLC, it still accesses content from the main game)?
    – CyberSkull
    Commented Sep 4, 2011 at 6:21
  • It's running from the disc.
    – Gup3rSuR4c
    Commented Sep 4, 2011 at 6:55

1 Answer 1


The Xbox 360 HDD uses a FAT32 filesystem and wraps all your stored data into 1GB sized proprietary disk images, so conventional hard drive tools may not do you much good.

Unfortunately, the Xbox 360 doesn't seem to have any low level data management/repair tools in the Dashboard.

Now, if I understand this correctly it looks like a disc read error. Since you say you have the 4GB model then you couldn't have installed Mass Effect 2 on there (average size per disc is 5.9GB, thus exceeding your HDD space).

Try cleaning the disc. To do so, get a microfiber cloth (the kind you would use on eyeglasses) and wipe from the center-out in a straight line. You may also want to use a small amount of distilled water to help get any dirt off.

If there is a prominent scratch you can try a DVD repair kit or just buy a really cheap used copy of Mass Effect 2 to replace the damange disc (it's cheaper to buy a used copy than to order a replacement disc).

Other advice:

Try to back up all of your saves to a USB memory stick (I recommend a 16GB version). I don't know about repairing the filesystem (MS support told me in the past they don't have very many tools for the Xbox HDD), so you may want to reformat the drive and let the Xbox reinstall the filesystem on it. Or you could purchase a used/refurbished 60GB drive and transfer all your save games to that. Don't back up your DLC, just re-download it.

Another edit: If all else fails, you might be able to get MS support to copy the data to a new device.

  • The "disc read" error is generic. It's the HDD that's damaged, not the CD. It's literally brand new out of the box and into the console. I have a 20GB HDD which is where everything is. I'm going to try using the Party Buffalo Drive Explorer to get my save files, transfer them to an Xbox compatible USB drive and reformat the HDD (if possible).
    – Gup3rSuR4c
    Commented Sep 4, 2011 at 6:57
  • What error did you get that leads you to believe it is the Kasumi DLC on the HDD that is the problem? Every disc read error I've had I can trace to a faulty DVD.
    – CyberSkull
    Commented Sep 4, 2011 at 7:10
  • Because I was playing the DLC specifically. Yes, the CD might be accessed during the process, but it's not the main source. Also, after I restarted my Xbox multiple times my profile was damaged and inaccessible. Since the profile resides on the HDD, I'm going to assume its the HDD.
    – Gup3rSuR4c
    Commented Sep 4, 2011 at 7:17
  • Did you delete your profile before recovering it or did you go straight into recover?
    – CyberSkull
    Commented Sep 4, 2011 at 7:20
  • Straight to recover. The profile doesn't always show up, depending on the restart...
    – Gup3rSuR4c
    Commented Sep 4, 2011 at 7:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .