1

I've been trying to open Minecraft for the good part of a day, and whenever I try to open the launcher it just crashes.

I am using a macOS 10.12.2 in a VM, trying to get portable Minecraft working. Even when I run the launcher without any special options, it crashes. Can anyone help?

Minecraft crash log: http://pastebin.com/raw/UQnJzXnQ

  • What version of minecraft are you using? – Nzall Dec 24 '16 at 22:04
6

Your Java is messed up.

If java is sigsegv-ing, that means it's borked. It's most likely not minecraft's fault, probably something about your VM. Did you install the latest java on the VM?

The three things it could be:

  • This is an old version of java, minecraft needs a newer one.

  • This is a newer version of java that's not backwards-compatible and minecraft can't run on it.

  • Your java is corrupted, meaning you should try to reinstall it. Do other applications that require java still work?

  • Whatever version of java is working with minecraft, but the java and/or minecraft don't work with macOS Sierra.

In my opinion, it's most likely #3. Basically, try reinstalling java. If that doesn't work, it's most likely minecraft not liking macOS Sierra. Sorry about that.

  • java is backwards compatible, and minecraft does work with the newest version of java – XeroOl Jan 6 '17 at 16:42
  • 1
    @XeroOl did it at the time though? OP hasn't responded whether the problem was fixed or not. – Riker Jan 16 '17 at 1:35
  • Java is and always has been backwards compatible. I always keep my java up to date (I program things in Java), and I've never had any issues with minecraft not launching. Minecraft has always worked with the newest version of java – XeroOl Jan 16 '17 at 5:09
  • My guess is that OP's Java installation is corrupted, not outdated / incompatible. – XeroOl Jan 16 '17 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.