3

I recently got the iBuffalo Usb Snes controller for my retropie build and booted up Super Mario World. Immediately I realized that when I would hold the y button down (to run and pick up and hold shells, etc) it wouldn't let me press any other buttons. If I turn on the turbo for the y button then it will run quicker, but never to the full extent required to jump higher or to hold shells. It seems that the controller only does a single fire type action for each button press, unless turbo is on which just repeatedly fires the action instead of doing what the original Snes would do.

I'm wondering if there is a setting that I can change that will provide me with the desired functionality using this controller or if I should return it and get one that will work (bonus points if you know of one that does work properly!).

Thanks!

1

The iBuffalo USB SNES controller issues are rather common, particularly in RetroPie and with ZSNES.

Several users in various forums (too many to cite specifically) report ghost button presses and the turbo function jacking up certain buttons.

From the RetroPie Forum wherein users are stating issue with iBuffalo pads specifically:

(From forum poster, 'gravvoid'

I was getting this issue with the iBuffalo controllers but I somehow seem to have fixed it. I went into the emulationstation config (/opt/retropie/configs/all/emulationstation/es_input.cfg) and removed the controller config for the controller entirely. I went back to onto my actual Pi after rebooting and set it up as a new contoller. Now it doesn't skip though the menus at all. The only difference made to the config file really, is that the iBuffalo input config is now at the very bottom of the input list instead of being the first on the list. I don't know or understand why this has made a difference but I'm not getting any ghost inputs at all. I've currently left it for over 2 hours and there's been no movement.

While he's specifically talking about ghosting, the general consensus is there's a problem with some controllers and the way RetroPie configures them and with the internal hardware of the iBuffalo (crystals) in some cases, making the combo a frustrating experience for some. Your issue is exactly this mix.

A more in-depth explanation of how to adjust things in RetroPie using the RetroArch configurations is on their github, here.

I haven't delved into the setting on that level, yet, for controllers.

Bonus Points:

Logitech F770 is what many are rocking and by all accounts, is well loved for its total lack of issues.

  • This totally solved my issue! And definitely going to look into getting an F770 as a universal controller. Thanks! – tmace Dec 30 '16 at 4:02
  • Glad it was helpful. Happy gaming . – Shawn Gordon Dec 30 '16 at 4:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.