14

So yesterday i downloaded and installed Steam to do some tests on moving the games off it onto my offline PC (for when The Legend of Heroes: Trails in the Sky the 3rd comes out) and I brought Original War and Commandos (the Bundle which has the first 4 proper games).

One thing I noticed was that Steam was slow as hell, not the internet speed (as Original War being ~1.3GB took 20 minutes to download) but the Steam Client itself. If I hovered over a menu option it would take 5-10 seconds before it would highlight and about that long to do what it would do after I click. Likewise when going into a text box to type in my username and password where I have to wait a few seconds for 8 characters to appear. When I try moving the window I click and drag the title bar but it doesn't follow and it can take more than 10s for the window to catch up to the cursor.

As I said this isn't an internet connection problem as at the same time I was on the internet (looking up where the Steam Games get downloaded to) and also about 20 minutes to download over 1GB is a new record for my laptop regarding something that isn't a torrent. I also know my laptop wasn't slow itself because Chrome and Explore was working just fine.

My laptop was a Windows 8 Laptop which got force upgraded to 10 but even then the Steam Client shouldn't be doing this; it's worse than how Minecraft plays on my laptop (which is quite poor - there is lag even on low settings) yet the Minecraft Launcher works just fine.

So why is my Steam Client acting so slow?

  • 2
    I have this occasionally myself - I usually find that restarting the Steam Client fixes it, but I have no idea why it happens! – JonK Jan 2 '17 at 22:30
  • There is a possibility it is your computer being slow itself because Chrome and Explorer are not as intense as Steam (although Steam is relatively lightweight). I would do what JonK says in the previous comment and try restarting steam. If that doesn't work reinstall, and if it still doesn't work, good luck. Could always check task manager and see if Steam appears to be taking up all of your processing power (CPU usage), and if that's the case, it is just your computer/laptop's issue which is beyond the scope of this forum. – Atom145 Jan 3 '17 at 18:02
  • How much RAM do you have? – DonielF Jul 12 '17 at 18:28
34

The fix I've found is to Clear the Steam application's Web Browser Cache.


I had this issue for a very long time. A previous workaround was to opt in to (or out of) the Steam client Beta. Only recently did I figure out the more targeted fix of clearing the cache.

Take note, this process and the fix I'm using may not work for everyone - and the batch script I made applies to Windows only. This is certainly adaptable to other systems, though I've never had this issue on macOS or Linux.


Manual in-app temporary fix

This will help confirm whether or not this is the cause of the slowness. It does of course require some patience:

  • From the tray icon: Right-click -> Settings; OR in the main client window menus: Steam -> Settings
  • In the Settings window that pops up, choose "Web Browser", usually toward the bottom left.
  • On that page, click the [ DELETE WEB BROWSER CACHE ] button.

The automated workaround:

For my desktop, I have replaced Steam's autostart with a task-scheduled batch script for two reasons:

  • The script clears the cache before launching Steam (this problem)
  • Task Scheduler allows you to delay tasks until after Network is operational (less chance of network/logon issues)

Script content. Notes below:

@echo off
TITLE CLEAR STEAM WEB CACHE BEFORE LAUNCHING
rmdir /s /q "%USERPROFILE%\AppData\Local\Steam\htmlcache"
mkdir "%USERPROFILE%\AppData\Local\Steam\htmlcache"

start C:\Steam\Steam.exe -nobigpicture
  • You can adjust the path appropriately depending on where Steam is installed
  • Other answers and articles mention other System paths - but I have confirmed via Process Monitor (from SysInternals) that the path I'm deleting is the only one that Steam itself clears. If someone has evidence otherwise, please let me know so I can add paths as appropriate.
  • I launch with the -nobigpicture parameter because, without it, Steam sometimes launches in "Big Picture" mode just because I have a controller attached. This parameter is optional.

Note that I have given up on finding a "proper" fix for this bug. Rather than clearing out the cache I now use a ramdisk for the affected folders.

In case these clues help another person trying to figure it out, best I can tell this is a bug in the browser back-end:

  • There is no obvious reason for the slowness. There is no CPU spike. There is no network latency. There is no disk I/O.
  • The browser backend (steamwebhelper.exe) is CEF (Chrome Embedded Framework), a sub-project of the Chromium Project.
  • When clearing the cache, rather than just immediately clearing the cache, steamwebhelper.exe is restarted as well.
  • This has saved my life. Did you find ever find out why the web cache was the issue? It's not like we don't have hard drive space or ram, right? – John Hamilton Jul 24 '17 at 18:53
  • 1
    Unfortunately not narrowed down 100%. Added notes to the end of the answer. Investigation ongoing. :-| – zaTricky Jul 25 '17 at 23:39
  • @zaTricky Such freezes in GUI happen when the GUI thread doesn't process messages fast enough. Since there is no CPU spike or anything, I can think only of one thing: it sleeps/waits for other threads/events inside the message loop, but with a short timeout so not to freeze completely. – Joker_vD Jul 26 '17 at 22:35
1

I don't know if this is still an open question, but here's a sloution that worked for me:

Go into control panel>internet options>connections tab>LAN options and untick "detect settings automatically"

restart steam client.

Good luck.

1

I found this solution from a Steam community link and it seems to have worked for me

In the Steam window: Steam > settings > interface > enable hardware decoding if supported

This was flagged OFF for me. I turned it ON, Steam restarted and the interface is fine again. After that I turned it OFF again, Steam restarted and the interface is still fine!

So at least by enabling this flag, it triggered Steam to rescan a setting and adjust it.

Seeing the wide variety of solutions I'm wondering what the cause of the problem is. In my case, I haven't changed my GPU, unlike what the OP in the forum link says.

Source: https://steamcommunity.com/discussions/forum/1/617328967241578199/

0

I think it's because of the HDD/SSD (your main drive) being too full. Also from personal experience, having cleared up some space on my main drive and used a disk clean tool to clean up temporary files, steam seems to be working normally now for me.

protected by Wrigglenite Jul 24 '17 at 21:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.