2

I recently upgraded my computer to play Steam games in better quality.

Whenever I play Fallout 4, the character starts with square rainbow colored skin. There is also severe asset glitching making it impossible to see anything in-game and leaving me feeling ill.

I've tried reinstalling the game twice and playing in both Bethesda's recommend settings as well as my video card's recommend settings.

I've tried searching the Bethesda forums. I've seen similar problems and solutions but for people with AMD graphics card. I've tried some of the solutions with no effect.

I do not know what I can do to fix it. My question is how to fix the visual errors to actually play the game.

My specs:

  • 1 TB HD
  • 16 GB RAM
  • 3.4 GHz
  • Nvidia GeForce 1060 3GB
  • Asus 29 inch gaming monitor
  • 120 GB SSD

Note: I am using the vanilla game. No mods installed.

EDIT: I have tried loading the game on each display setting to no effect. I have looked into the godrays/shadows/and shadow distance with no impact on the problem. I had a third party take screenshots since the game makes me ill currently and will attach them below. I have seen that the game actually downloaded to the SSD. I'm not sure if that fact makes a difference though. Due to the size limits I can only attach one picture; however, it does give an example of the broken texture.

Standing in entrance to living room

  • Drivers all up to date on that GeForce? – Kaizerwolf Jan 4 '17 at 14:55
  • Maybe try this. – Timmy Jim Jan 4 '17 at 15:01
  • Have you tested the gpu memory with something like Furmark? How do other 3d applications perform? – David Yell Jan 4 '17 at 16:57
  • All the drivers are up to date. That solution is for AMD but I will try it after I'm off work tonight regardless. Regarding other 3d applications: I can play things like Rust on high settings. I also have battlefield 1 rendering no problem on low-medium settings. – DanSchneiderNA Jan 4 '17 at 17:16
  • What OS are you running? – Shawn Gordon Jan 4 '17 at 17:21
3

Found a solution. It is indeed "Godrays".

Unfortunately, even if you turn them off the game doesn't fully turn them off so you have to turn them off in the ini.

Go to Fallout4Pref.ini

Under [Display] change the following to exactly this: iVolumetricLightingQuality=0 bVolumetricLightingEnable=0

After you change them both to 0, save the file.

Then go to the properties and make it read only. If you do not change it to "Read Only" Fallout will automatically switch this setting back.

Launch Fallout and enjoy it Rainbow free.

The problem is located with the Shadow Shaders in the game, these 2 settings were introduced for AMD GPUs because NVIDIA had this setting built in. After 1.3 for some reason it broke and the God Rays break the shadow shader for some reason. Its much more complicated than this, but I say this just to make a long story short.

The problem isn't in the textures themselves, but the way shadows interact with the surface textures.

I am unsure if this will fix your other graphical issues, but this should at least fix the rainbow problem.

  • Thank you! This along with the answer I have fixed the rainbow textures and the broken textures. – DanSchneiderNA Jan 22 '17 at 17:15
1

So after a while I've narrowed it down to either an error with my NVIDIA Card and/or error with the Intel graphics card.

To fix the problem with broken textures I completely uninstalled by NVIDIA and Intel graphics followed by redownloading and updating the graphics card.

Since uninstalling and reinstalling the graphics cards I have not had a problem with the textures in Fallout 4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.