1

I have run into a persistent bug concerning Space Engineers (now in BETA, so it isn't assumed this is a finished title or wold be free of some bugs). However the persistent bug I've run into is a known but thought to be fully addressed bug: Black Screen after system wake. This type of issue isn't unique to Space Engineers nor Windows. I've read a few other questions in Arqade regarding the Black Screen issues, and while some of them do have some helpful tips - none of them specifically address or solve the issue I seem to have. Additionally, websites specifically discussing the issue with Space Engineers do help many with this problem except they didn't work for me this time around.

This was not something I was hit with in the earlier versions, and I have tried several things (including simply waiting to see if subsequent updates wold address it directly or indirectly.

Failed solution 1:

Though this solution worked for some users, I did not that the solution was posted in the latter half of 2013.

...open the SpaceEngineers.cfg file (you need to open it with notepad)

Look for this:

Key xsi:type="xsd:string">RefreshRate</Key>
<Value xsi:type="xsd:string">0</Value> "

Then change the >0< value to whatever refresh rate that normally works for you, and then save the file.

In my case changing it to >59< fixed it for me.

In the comment tree of this solution proposal, the developer commented the next update would address half of affected systems and that some of it was due to the some users installing Space Engineers on a drive other what Steam wants to default.

I also understand that sometimes, hardware drivers and settings can sort of interfere with performance, particularly when coming out of sleep or hibernation modes, and I found that this specific issue has been linked to audio drivers before.

Fortunately the developer's website had another potential solution. Unfortunately it did not work for my issue, either.

Unsuccessful attempt to solve 2:

(MAKE SURE YOU CLOSE SPACE ENGINEERS FIRST, MAKE SURE IT IS NOT RUNNING CHECK THE TASK MANAGER AS WELL AND KILL IT IF IT IS).

You need to access your default Playback Device advanced options and set your device's default format to a more common standard...

To do this... (WINDOWS INSTRUCTIONS, COULD BE SIMILAIR TO OTHER OPERATING SYSTEMS)

  1. Right click on the icon in your taskbar that is the speaker.
  2. Select "Playback Devices" from the drop down (Or shell context hurr) menu.

  3. Right click your default device (marked by a green arrow or says 'default device' beneath it).

  4. Select "Properties" from the drop down menu.
  5. Select the "Advanced" tab.
  6. Now under the "Default Format" field you'll see a drop box. MY default format WAS set to the highest available quality for the device...

24-bit, 192000 Hz...

Sometimes this can cause issues. So I CHANGED IT TO...

24-bit, 48000 Hz...

(A more common, less demanding, lower quality type format for lower end PCs or PCs lacking a good audio device).

BUT FOR YOU. If you want to try the same format as me that MIGHT be best to try INITIALLY and if that doesn't work START FROM THE LOWEST QUALITIES (Lower Hz) and try running the game with them and see if it works. The lower quality formats are GENERALLY more easily or more commonly supported.

(NOTE: YOU MIGHT HAVE TO TURN THE AUDIO BACK ON IN-GAME WHEN YOU LOAD IT UP AGAIN AFTER CHANGING YOUR AUDIO DEVICE'S DEFAULT FORMAT).

Third time's a charm, right?

Moving closer to the direct source page (which I did not do since typically beta software support pages are dealing with revolving issues in priority order). the Space Engineers website dropped a boilerplate graphics and performance support statement: "set it up in your nVidia Control Panel."

NOTE: NVidia has included the profile for Space Engineers in their latest drivers so if you experience this issue, please update your NVidia drivers to the latest version and then go to settings and check the option to run Space Engineers on the NVidia card.

If you still experience this problem, you can try the following:

disable integrated GPU (best in BIOS) or configure your Nvidia GPU: Instructions: If you're using a newer laptop that you know has an NVidia graphics card, try checking your preferred graphics settings. Open the "NVIDIA Control Panel" from your start menu. On the left hand side, under "Select a task...", open the "3D Settings" tree, and select "Manage 3D Settings". Now on the righthand panel, click the "Program Settings" tab. Under "1. Select a program...", click "Add", navigate to your \Steam\steamapps\common\SpaceEngineers directory and select " SpaceEngineers.exe". Under "2. Select the preferred graphics...", choose "High-performance NVIDIA processor", then (VERY IMPORTANT) click "Apply" in the bottom right.

I will note however, that I did also carefully review the section of the support page that made note of Windows 10 issues, none of which applied to my situation. I have accounted for the fact that V Sync sometimes creates an issue with the display driver, and I don't have that on, and as the last solution suggests I have Space Engineers set to use the nVidia card within game settings.

What other possible solutions could I attempt, please and thank you?


Pertinent System Spec.

Lenovo Y700-17ISK

  • Windows 10 Home (64-bit, ver 10.0.14393)
  • Intel Core i7-6700HQ @ 2.6Ghz
  • Intel HD Graphics 530
  • nVidia 960M, 4GB (driver version 376.33 WHQL)

Steam Client

  • Built: Dec 19, 2016
  • Steam API v017
  • This question doesn't belong here but on the SE forum or support. – BadAtPHP Jan 9 '17 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.