I was trying to install a mod, but it didn't work and I deleted the mod files. I went to play Minecraft, but it just launched to a black screen.

I clicked "Force Update", but Minecraft gave the following error:

Failed to Launch Fatal Error Occurred (4): /Users/(my name)/Library/Application Support/minecraft/bin/minecraft.jar

I tried deleting Minecraft and redownloading, but that didn't work, nor did waiting a day to see if the problem resolved itself.

How can I redownload the files for Minecraft on Mac so I can get back to playing?

  • Er, did you mean Notch? Sep 6, 2011 at 21:18

3 Answers 3


When you download Minecraft for Mac, you download an application file which you then place in your Applications folder. But that's just a wrapper for the "real" Minecraft binary files (a set of JAR files), which gets downloaded into your Application Support folder.

So when you delete and redownload the Minecraft application, you haven't done anything about the actual binaries already downloaded and being used. If these are corrupted (as they appear to be in your situation), they won't be fixed by redownloading the Minecraft application.

While "Force update" should do something about these files, you can do something about it yourself by manually deleting the downloaded JAR files.

To do this, you'll need to navigate to the path described in the error. In Finder, go to the Go menu and select Go to Folder... Type in the following:

~/Library/Application Support/minecraft

and click the Go button. Finder will open a new folder with a few subfolders, including one labeled bin. Throw the bin folder in the Trash and empty it.

Now go back into your Applications folder and open Minecraft. Minecraft will then redownload its binaries and the problem should be resolved.


Sorry, I didn't fully read your post

You can try deleting all of the contents of your ~/Library/Application Support/minecraft, except for saves, then try the 'Force Update' option.


You can use the force download option in the Minecraft launcher to redownload the default Minecraft JAR.

Once in the Login screen, choose 'Options' and click the 'Force Update' button. That will download the new JAR as well as the platform-specific files.


I had the same error but I got it to work with the following steps:

  1. Delete the minecraft app support folder.

  2. Go to minrcraft.net and play in browser for few minutes.

  3. Download minecraft.

  4. Rename minecraft to some other random name.

  5. Authenticate it.

  6. Go to ~/Library/Application Support/minecraft to check if the files are re- downloaded (they should be).

  7. Start minecraft

This worked for me!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .