Both Gmod and TF2 only show me like 10 servers, yet games like tabletop simulator shows all server available, so i know there is a problem with source games.

I tried lowering max ping and clear download cache, but nothing happens.

  • Did you try one of these (or all of them)? -> check/disable anti virus (especially Norton is a pain), check your proxy settings (try it without proxy), add port forwarding rules for common Steam ports in your firewall/router.
    – dly
    Commented Jan 19, 2017 at 7:31
  • How long have you waited? It may take some time for Gmod to find all available servers.
    – creulcat
    Commented Jan 19, 2017 at 8:12
  • 2
    Also there is an option on Steam to limit server discovery rate. In this case it will take some time to list all available servers. I highly doubt you activated it without knowing, cause many never ever discover it even when searching.
    – Sanctus
    Commented Jan 19, 2017 at 12:06

1 Answer 1


All source games use the same algorythm of discovering servers:

  • the game asks valve's masterserver for a server list, receiving a list of IP addresses
  • the game now sends an A2S_INFO UDP packet to each server in a list, at a maximum rate of 250-5000 pings per minute.

  • every servers responds with an UDP response packet containing some useful information

Why this happens

Most likely, your internet connection have issues with UDP packets: packet loss, extreme delaying, restrictive filter, etc etc. - packets between you and internet servers lost.. somehow.

What you can do

1. Decrease server query rate

Rate is guessed by steam client, but it's also configurable in

Settings -> In-game -> In-Game Server browser: Max pings / minute

Settings -> In-game -> In-Game Server browser: Max pings / minute

2. Hit refresh servers button again

With my 3G connection it takes multiple clicks, and from 5 to 30 seconds before servers in TF2 client start to appear.

3. Troubleshoot network issues

Anti-virus, firewall or other software may interfere, try disabling it.

Bad hardware (notably your router) can interfere - try connecting to internet directly (if your pc connected to isp through router)

If none helps, you can call your ISP's customer support.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .